# Problem installing Mautic 5.2.3 - 500 Internal Server Error

**URL:** <https://forum.mautic.org/t/problem-installing-mautic-5-2-3-500-internal-server-error/35248>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [March 11, 2025, 4:19pm UTC](https://forum.mautic.org/t/problem-installing-mautic-5-2-3-500-internal-server-error/35248 "2025-03-11T16:19:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ccamusso](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ccamusso/32/14033_2.png) [@ccamusso](https://forum.mautic.org/u/ccamusso)\
**Post date:** [March 11, 2025, 4:19pm UTC](https://forum.mautic.org/t/problem-installing-mautic-5-2-3-500-internal-server-error/35248/1 "2025-03-11T16:19:43Z")

</div>

**My system**

- Almalinux 9
- Apache 2.4.62
- PHP 8.2.27
- Mysql 8.0.41
- packege Mautic 5.2.3

**My installation step**

**Step 1**  
I open the website where Mautic is hosted.  
The environment check is perfect, and the SSL configuration is correctly present.  
I click on ‘Next Step’.

**Step 2**  
I configure the database access parameters.  
I click on ‘Next Step’.  
The tables are successfully created in MySQL.

**Step 3**  
I configure the administrator’s username, password, first name, last name, and email.  
I click on ‘Next Step’.

**I get the following error:**  
_“Uh oh! I think I broke it. If I do it again, please report me to the system administrator!_  
_‘500 Internal Server Error’”_

This log file is empty:

- /var/log/httpd/error\_log
- /var/log/php-fpm/error.log

Can you help me?

---

<div class="post-metadata">

**Author:** ![ccamusso](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ccamusso/32/14033_2.png) [@ccamusso](https://forum.mautic.org/u/ccamusso)\
**Post date:** [March 12, 2025, 1:56pm UTC](https://forum.mautic.org/t/problem-installing-mautic-5-2-3-500-internal-server-error/35248/2 "2025-03-12T13:56:57Z")

</div>

I fixed it.

By enabling Mautic’s debug mode, I saw that the issue was with Doctrine.

I shared the error (retrieved from Mautic’s log files) with ChatGPT, and it provided me with the sequence of commands to fix it.

```auto
sudo rm -rf /var/www/html/mautic5/var/cache/*
sudo rm -rf /var/www/html/mautic5/var/cache/prod/*
sudo -u apache php /var/www/html/mautic5/bin/console cache:clear
sudo php /var/www/html/mautic5/bin/console cache:clear
sudo -u apache php /var/www/html/mautic5/bin/console doctrine:cache:clear-metadata
sudo -u apache php /var/www/html/mautic5/bin/console doctrine:cache:clear-query
sudo -u apache php /var/www/html/mautic5/bin/console doctrine:cache:clear-result
sudo -u apache php /var/www/html/mautic5/bin/console cache:clear
sudo -u apache php /var/www/html/mautic5/bin/console doctrine:mapping:info
sudo chown -R apache:apache /var/www/html/mautic5/var/cache
sudo chmod -R 775 /var/www/html/mautic5/var/cache
sudo systemctl restart httpd
sudo systemctl restart php-fpm

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/1X/43c63600fe51440378769136903f1fa2a9a34102.png) [@system](https://forum.mautic.org/u/system)\
**Post date:** [March 14, 2025, 1:56am UTC](https://forum.mautic.org/t/problem-installing-mautic-5-2-3-500-internal-server-error/35248/3 "2025-03-14T01:56:59Z")

</div>

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.
