# Problem setting language

**URL:** <https://forum.mautic.org/t/problem-setting-language/2096>\
**Category:** Product Support\
**Created:** [July 28, 2015, 9:35am UTC](https://forum.mautic.org/t/problem-setting-language/2096 "2015-07-28T09:35:32Z")\
**Posts on this page:** 9\
**Page:** 2

<div class="post-metadata">

**Author:** ![ralfhug](https://avatars.discourse-cdn.com/v4/letter/r/8dc957/32.png) [@ralfhug](https://forum.mautic.org/u/ralfhug)\
**Post date:** [February 10, 2016, 1:28pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/21 "2016-02-10T13:28:18Z")

</div>

I’m on GoDaddy Hosting in Germany running PHP 5.4 and latest Mautic version.

I’m trying to set language to German and get following error:

[2016-02-10 13:11:58] mautic.ERROR: Fatal: Class ‘ZipArchive’ not found - in file /home/xxx/public\_html/mautic/app/bundles/CoreBundle/Helper/LanguageHelper.php - at line 77 [] []

Line 77 is:  
$zipper = new ZipArchive();

I also added @myflower code Feb 4 but error still occurs.

Appreciate any help.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 10, 2016, 1:30pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/22 "2016-02-10T13:30:48Z")

</div>

@ralfhug : [http://stackoverflow.com/questions/3872555/fatal-error-class-ziparchive-not-found-in](http://stackoverflow.com/questions/3872555/fatal-error-class-ziparchive-not-found-in)

---

<div class="post-metadata">

**Author:** ![ralfhug](https://avatars.discourse-cdn.com/v4/letter/r/8dc957/32.png) [@ralfhug](https://forum.mautic.org/u/ralfhug)\
**Post date:** [February 10, 2016, 3:17pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/23 "2016-02-10T15:17:47Z")

</div>

@escopecz. Unfortunately I am not a tech expert and don’t know what to do with those instructions. I understand I have to do this:

“For the ZipArchive class to be present, PHP needs to have the zip extension installed.”

However, the links to do it are not as clear for me to actually do it. It says:

“In order to use these functions you must compile PHP with zip support by using the --enable-zip configure option.”

I’m on Godaddy Linux hosting.

By the way I found the language zip file in my cache which you wanted me to clear for the cron install on another post.

Thanks for your help.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 10, 2016, 3:21pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/24 "2016-02-10T15:21:03Z")

</div>

Ok, then contact Godaddy hosting and ask them if they could install the ZipArchive PHP extension for you.

---

<div class="post-metadata">

**Author:** ![ralfhug](https://avatars.discourse-cdn.com/v4/letter/r/8dc957/32.png) [@ralfhug](https://forum.mautic.org/u/ralfhug)\
**Post date:** [February 10, 2016, 4:33pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/25 "2016-02-10T16:33:34Z")

</div>

@escopecz. Ok, I did install zipArchive PHP extension by enabling zip in cpanel on PHP 5.4. After clearing cache it worked. Thanks

---

<div class="post-metadata">

**Author:** ![oncon](https://avatars.discourse-cdn.com/v4/letter/o/ecc23a/32.png) [@oncon](https://forum.mautic.org/u/oncon)\
**Post date:** [September 24, 2016, 7:38am UTC](https://forum.mautic.org/t/problem-setting-language/2096/26 "2016-09-24T07:38:35Z")

</div>

Hi,

I have problem with instalation CZECH language. Error log write:

[quote][2016-09-24 08:32:04] mautic.ERROR: Uncaught PHP Exception SymfonyComponentHttpKernelExceptionNotFoundHttpException: “Requested URL not found: /s/config” at /home/domains/domain.cz/web/public/mautic/app/bundles/CoreBundle/Controller/CommonController.php line 430 {“exception”:"[object] (Symfony\Component\HttpKernel\Exception\NotFoundHttpException(code: 0): Requested URL not found: /s/config at /home/domains/domain.cz/web/public/mautic/app/bundles/CoreBundle/Controller/CommonController.php:430)"} []  
[2016-09-24 08:32:32] mautic.WARNING: PHP Warning: realpath(): open\_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/domains/domain.cz/web/) - in file /home/domains/domain.cz/web/public/mautic/vendor/phpoffice/phpexcel/Classes/PHPExcel/Shared/File.php - at line 175 [] []  
[2016-09-24 08:32:32] mautic.CRITICAL: Uncaught PHP Exception SymfonyComponentDebugExceptionFatalErrorException: “Compile Error: require\_once(): Failed opening required ‘PHPEXCEL\_ROOTPHPExcel/Shared/PCLZip/pclzip.lib.php’ (include\_path=’.:/usr/share/php’)” at /home/domains/domain.cz/web/public/mautic/vendor/phpoffice/phpexcel/Classes/PHPExcel/Shared/ZipArchive.php line 31 {“exception”:"[object] (Symfony\Component\Debug\Exception\FatalErrorException(code: 0): Compile Error: require\_once(): Failed opening required ‘PHPEXCEL\_ROOTPHPExcel/Shared/PCLZip/pclzip.lib.php’ (include\_path=’.:/usr/share/php’) at /home/domains/domain.cz/web/public/mautic/vendor/phpoffice/phpexcel/Classes/PHPExcel/Shared/ZipArchive.php:31)"} []  
[2016-09-24 08:32:32] mautic.ERROR: Notice: require\_once(): Failed opening required ‘PHPEXCEL\_ROOTPHPExcel/Shared/PCLZip/pclzip.lib.php’ (include\_path=’.:/usr/share/php’) - in file /home/domains/domain.cz/web/public/mautic/vendor/phpoffice/phpexcel/Classes/PHPExcel/Shared/ZipArchive.php - at line 31 [] [][/quote]

I have php 7 on my server.

Can somebody help me?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 26, 2016, 6:45am UTC](https://forum.mautic.org/t/problem-setting-language/2096/27 "2016-09-26T06:45:03Z")

</div>

Ask your server provider about this:

> [@](#):
>
> realpath(): open\_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/domains/domain.cz/web/)

---

<div class="post-metadata">

**Author:** ![tasselhof](https://avatars.discourse-cdn.com/v4/letter/t/b2d939/32.png) [@tasselhof](https://forum.mautic.org/u/tasselhof)\
**Post date:** [February 21, 2017, 2:44pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/28 "2017-02-21T14:44:56Z")

</div>

Can be also resolved by installing zip PHP extension: (Solution for Ubuntu)

```auto
sudo apt-get install php7.0-zip
sudo service apache2 restart
```

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:59pm UTC](https://forum.mautic.org/t/problem-setting-language/2096/29 "2020-02-02T22:59:13Z")

</div>



[Previous page](https://forum.mautic.org/t/problem-setting-language/2096.md?page=1)
