# Problem with backup and restore in mySQL (columns generated)

**URL:** https://forum.mautic.org/t/problem-with-backup-and-restore-in-mysql-columns-generated/23324
**Category:** Product Support
**Created:** [March 28, 2022, 10:55am UTC](https://forum.mautic.org/t/problem-with-backup-and-restore-in-mysql-columns-generated/23324 "2022-03-28T10:55:20Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![jribeiro](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/jribeiro/32/1003_2.png) [@jribeiro](https://forum.mautic.org/u/jribeiro)
#### Post date: [March 28, 2022, 10:55am UTC](https://forum.mautic.org/t/problem-with-backup-and-restore-in-mysql-columns-generated/23324/1 "2022-03-28T10:55:20Z")

</div>

**Your software**  
My Mautic version is: 4.1.2  
My PHP version is: 7.4  
My Database type and version is: mySQL 8.0.27

This is a general problem. I had to restore the database from standard mySQL backup and it fails

The hosting company has restored it but sent this message (google translated from Spanish)

Currently the import of the backup has been able to be completed by the administrators. However, they inform us that until the error related to “GENERATED” columns on MySQL is solved, it will not be possible to carry out this type of exceptional imports.

Therefore, before executing a database export, we recommend that you check the database from PHPMyAdmin to edit those types of columns.

And these are the changes they have proposed in the Mautic DB structure

\*sed -i ‘s/(`generated_sent_date` date).+/\1,/’ dump.sql  
\*\*sed -i ‘s/(`generated_email_domain` varchar(255)).+/\1,/’ dump.sql

I think this need to be changed to avoid restore problems
