# Problems installing Mautic 5 on fresh VPS

**URL:** <https://forum.mautic.org/t/problems-installing-mautic-5-on-fresh-vps/30422>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [January 10, 2024, 9:40am UTC](https://forum.mautic.org/t/problems-installing-mautic-5-on-fresh-vps/30422 "2024-01-10T09:40:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![aysal](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aysal/32/13028_2.png) [@aysal](https://forum.mautic.org/u/aysal)\
**Post date:** [January 10, 2024, 9:40am UTC](https://forum.mautic.org/t/problems-installing-mautic-5-on-fresh-vps/30422/1 "2024-01-10T09:40:48Z")

</div>

Hi there,  
very exited to switch to Mautic i rented a vps, installed an ubuntu image and now i have problems installing mautic.

abter a lot of steps i was able to run a “php8.1 /usr/bin/composer install”

It leads to an error:

```auto
757 verbose stack Error: command failed
757 verbose stack at ChildProcess.<anonymous> (/usr/share/nodejs/@npmcli/promise-spawn/index.js:64:27)
757 verbose stack at ChildProcess.emit (events.js:314:20)
757 verbose stack at maybeClose (internal/child_process.js:1022:16)
757 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)
758 verbose pkgid mautic@0.0.0
759 verbose cwd /var/www/mautic
760 verbose Linux 5.15.0-91-generic
761 verbose argv "/usr/bin/node" "/usr/bin/npm" "ci" "--prefer-offline" "--no-audit"
762 verbose node v12.22.9
763 verbose npm v8.5.1
764 error code 137
765 error path /var/www/mautic
766 error command failed
767 error command sh -c node_modules/modernizr/bin/modernizr -c modernizr-config.json -d node_modules/modernizr/modernizr-mautic-dist.js & npm run build
768 verbose exit 137
769 timing npm Completed in 351983ms
770 verbose code 137
771 error A complete log of this run can be found in:
771 error /root/.npm/_logs/2024-01-10T09_00_57_324Z-debug-0.log

```

I am really new in composer - can someone help me?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [January 10, 2024, 10:50am UTC](https://forum.mautic.org/t/problems-installing-mautic-5-on-fresh-vps/30422/2 "2024-01-10T10:50:59Z")

</div>

By a quick Google search it looks like the code 137 is caused by hitting the memory limit. One of the first Google links:

> <https://stackoverflow.com/questions/68604735/how-to-solve-npm-run-build-137-error-already-have-set-10gb>
