# Salesforce plugin

**URL:** <https://forum.mautic.org/t/salesforce-plugin/3441>\
**Category:** Product Support\
**Created:** [February 11, 2016, 1:27pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441 "2016-02-11T13:27:03Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 11, 2016, 1:27pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/1 "2016-02-11T13:27:03Z")

</div>

Hi,  
  
I’ve succesfully setup Mautic on our website.  
  
Now I’d like to link it to our salesforce system, but I keep ketting an error.  
  
I followed the setup, created a consumer key and secret, but I keep getting the error they are not valud.  
  
error\_invalid\_client\_id & error description: client identifier invalid.  
  
I’m using version 1.2.4

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 11, 2016, 1:27pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/2 "2016-02-11T13:27:03Z")

</div>

Hi,  
I’ve succesfully setup Mautic on our website.  
Now I’d like to link it to our salesforce system, but I keep ketting an error.  
I followed the setup, created a consumer key and secret, but I keep getting the error they are not valud.  
error\_invalid\_client\_id & error description: client identifier invalid.  
I’m using version 1.2.4

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 11, 2016, 5:16pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/3 "2016-02-11T17:16:47Z")

</div>

Some more information, screenshots  
 ![](http://www.chili-publish.com/media/mautic.png)  
 ![](http://www.chili-publish.com/media/sf.png)

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 12, 2016, 10:56am UTC](https://forum.mautic.org/t/salesforce-plugin/3441/4 "2016-02-12T10:56:25Z")

</div>

If all the steps from [https://www.mautic.org/docs/plugins/salesforce.html](https://www.mautic.org/docs/plugins/salesforce.html) are met, then probably ask Salesforce support if they get the request and if so, why it throws the error. Maybe they’ll be able to tell you more.

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 12, 2016, 12:43pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/5 "2016-02-12T12:43:23Z")

</div>

I logged a case with Salesforce. See what happens there, but meanwhile, I kept trying, and noticed that the client\_id passed in the URL (rest API) is not passed along.  
Also, when I look into the database, I don’t find the data in there.  
Is there something I need to do, to save the consumer\_id and key in the database?  
All other data (leads, campaigns, …) are stored, and working correctly.

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 12, 2016, 12:44pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/6 "2016-02-12T12:44:16Z")

</div>

PS I even tried to change the url from [login.salesforce.com](http://login.salesforce.com) to our unique url. (some tip I found on salesforce fora for other oauth integrations) But not luck with that.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 12, 2016, 1:51pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/7 "2016-02-12T13:51:13Z")

</div>

Where were you looking in the database for the stored client key?

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 12, 2016, 3:32pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/8 "2016-02-12T15:32:06Z")

</div>

Tried to search through all tables in de MySQL database, but specifically in the oauth1\_ and oauth2\_ tables  
But I also noticed in the UI that the consumer id is not saved. Maybe because the process did not go through, but in the popup of salesforce, it’s also not passed in the URL.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 12, 2016, 3:51pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/9 "2016-02-12T15:51:30Z")

</div>

The key is not loaded back to the edit formula each time for security reasons. It is stored in the plugin\_integration\_setting table if you’d like to check it is really stored.

---

<div class="post-metadata">

**Author:** ![Karan](https://avatars.discourse-cdn.com/v4/letter/k/58f4c7/32.png) [@Karan](https://forum.mautic.org/u/Karan)\
**Post date:** [February 15, 2016, 10:21pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/10 "2016-02-15T22:21:18Z")

</div>

Hi,

Its a bug in mautic itself. The URL to sales force does not contain the client id. If I put the client id manually it works. Also the salesforce dialog does not save the data.

---

<div class="post-metadata">

**Author:** ![Karan](https://avatars.discourse-cdn.com/v4/letter/k/58f4c7/32.png) [@Karan](https://forum.mautic.org/u/Karan)\
**Post date:** [February 15, 2016, 10:40pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/11 "2016-02-15T22:40:52Z")

</div>

When i put the details in the salesforce dialog, this the error in the logs

[2016-02-15 22:38:38] mautic.WARNING: PHP Warning: mcrypt\_encrypt(): Key of size 5 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported - in file C:inetpubVirtual Hoststest.localhostappbundlesCoreBundleHelperEncryptionHelper.php - at line 60 [] []

---

<div class="post-metadata">

**Author:** ![Karan](https://avatars.discourse-cdn.com/v4/letter/k/58f4c7/32.png) [@Karan](https://forum.mautic.org/u/Karan)\
**Post date:** [February 15, 2016, 10:50pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/12 "2016-02-15T22:50:00Z")

</div>

Ok sorted, php version 5.6 gives this problem. when I changed to 5.5 all working okay

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 16, 2016, 12:51pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/13 "2016-02-16T12:51:13Z")

</div>

Hi, any chance on an update? I don’t have the option of downgrading our webserver.  
A possible workaround?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 17, 2016, 12:30pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/14 "2016-02-17T12:30:17Z")

</div>

It seems a lot like the problem which will be fixed by this PR in the next Mautic version:

[https://github.com/mautic/mautic/pull/1396](https://github.com/mautic/mautic/pull/1396)

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 17, 2016, 2:32pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/15 "2016-02-17T14:32:58Z")

</div>

Thanks would be perfect. Tx

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 17, 2016, 5:13pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/16 "2016-02-17T17:13:45Z")

</div>

@Bram I mean I’m not sure about it and you can modify the code of your Mautic the way the pull request shows and confirm it fixed it for you. Or you can wait if the new Mautic version will work for you, sure.

---

<div class="post-metadata">

**Author:** ![Bram](https://avatars.discourse-cdn.com/v4/letter/b/9d8465/32.png) [@Bram](https://forum.mautic.org/u/Bram)\
**Post date:** [February 29, 2016, 2:58pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/17 "2016-02-29T14:58:57Z")

</div>

hi @escopecz Any idea when this version might be released? Or can you give me a hint in what files I need to look?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 29, 2016, 3:04pm UTC](https://forum.mautic.org/t/salesforce-plugin/3441/18 "2016-02-29T15:04:28Z")

</div>

@Bram If you look at the PR I lined to earlier closely, you’ll see it already have the “Merged” tag so it should be part of the 1.3.0 release which should go out today, yey! And it also have the “Files changed” tab where you can see the files and rows which were changed. I know it takes a while to get familiar with GitHub. But usually, everything you are looking for is there.
