# Tags, segments or landing page the page loads and stays where it was v4.3.1

**URL:** <https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294>\
**Category:** Product Support\
**Created:** [May 31, 2022, 7:34pm UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294 "2022-05-31T19:34:39Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![marcopalacio](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marcopalacio/32/7677_2.png) [@marcopalacio](https://forum.mautic.org/u/marcopalacio)\
**Post date:** [May 31, 2022, 7:34pm UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294/1 "2022-05-31T19:34:39Z")

</div>

My Mautic version is: v4.3.1  
My PHP version is: 7.4  
My Database type and version is: mysql

My problem is: when you try to enter tags, segments or landing page the page loads and stays where it was.

If I try to open any of these sections in a new tab it gives error 500

In the log it shows me the following error: [2022-05-31 16:32:17] mautic.CRITICAL: Uncaught PHP Exception Doctrine\DBAL\Exception\InvalidFieldNameException: “An exception occurred while executing ‘SELECT COUNT(_) AS dctrn\_count FROM (SELECT DISTINCT id\_10 FROM (SELECT l0\_.is\_published AS is\_published\_0, l0\_.date\_added AS date\_added\_1, l0\_.created\_by AS created\_by\_2, l0\_.created\_by\_user AS created\_by\_user\_3, l0\_.date\_modified AS date\_modified\_4, l0\_.modified\_by AS modified\_by\_5, l0\_.modified\_by\_user AS modified\_by\_user\_6, l0\_.checked\_out AS checked\_out\_7, l0\_.checked\_out\_by AS checked\_out\_by\_8, l0\_.checked\_out\_by\_user AS checked\_out\_by\_user\_9, l0\_.id AS id\_10, l0\_.name AS name\_11, l0\_.description AS description\_12, l0\_.alias AS alias\_13, l0\_.public\_name AS public\_name\_14, l0\_.filters AS filters\_15, l0\_.is\_global AS is\_global\_16, l0\_.is\_preference\_center AS is\_preference\_center\_17, l0\_.last\_built\_date AS last\_built\_date\_18 FROM lead\_lists l0\_ LEFT JOIN categories c1\_ ON l0\_.category\_id = c1\_.id ORDER BY l0\_.date\_modified DESC) dctrn\_result) dctrn\_table’: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘l0\_.last\_built\_date’ in ‘field list’" at /home/u390877933/domains/alma-negocios.com/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 79 {“exception”:"[object] (Doctrine\DBAL\Exception\InvalidFieldNameException(code: 0): An exception occurred while executing 'SELECT COUNT(_) AS dctrn\_count FROM (SELECT DISTINCT id\_10 FROM (SELECT l0\_.is\_published AS is\_published\_0, l0\_.date\_added AS date\_added\_1, l0\_.created\_by AS created\_by\_2, l0\_.created\_by\_user AS created\_by\_user\_3, l0\_.date\_modified AS date\_modified\_4, l0\_.modified\_by AS modified\_by\_5, l0\_.modified\_by\_user AS modified\_by\_user\_6, l0\_.checked\_out AS checked\_out\_7, l0\_.checked\_out\_by AS checked\_out\_by\_8, l0\_.checked\_out\_by\_user AS checked\_out\_by\_user\_9, l0\_.id AS id\_10, l0\_.name AS name\_11, l0\_.description AS description\_12, l0\_.alias AS alias\_13, l0\_.public\_name AS public\_name\_14, l0\_.filters AS filters\_15, l0\_.is\_global AS is\_global\_16, l0\_.is\_preference\_center AS is\_preference\_center\_17, l0\_.last\_built\_date AS last\_built\_date\_18 FROM lead\_lists l0\_ LEFT JOIN categories c1\_ ON l0\_.category\_id = c1\_.id ORDER BY l0\_.date\_modified DESC) dctrn\_result) dctrn\_table’:\n\nSQLSTATE[42S22]: Column not found: 1054 Unknown column ‘l0\_.last\_built\_date’ in ‘field list’ at /home/u390877933/domains/alma-negocios.com/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:79, Doctrine\DBAL\Driver\PDO\Exception(code: 42S22): SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘l0\_.last\_built\_date’ in ‘field list’ at /home/u390877933/domains/alma-negocios.com/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDO/Exception.php:18, PDOException(code: 42S22): SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘l0\_.last\_built\_date’ in ‘field list’ at /home/u390877933/domains/alma-negocios.com/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:141)”} {“hostname”:“us-imm-web219.main-hosting.eu”,“pid”:1360}

I tried to clear cache but it still doesn’t work.

I want to clarify that I do not know about programming or many technical issues

Here a video to visualize the error

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [May 31, 2022, 7:42pm UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294/2 "2022-05-31T19:42:28Z")

</div>

This suggests that you have some database migrations which have not been run. Did your update get stuck at any point in the past?

Try to follow these steps (take a backup of your instance and the database first).

> **[Mautic update failed - how to recover](https://docs.mautic.org/en/troubleshooting/update-failed)**
>
> . Sometimes when updating Mautic, the process might stall or fail part way through. This can cause a problem, because it can cause Mautic to be inbetween two versions and often this can make the system unusable.. . . . . . Generally speaking, updates...

---

<div class="post-metadata">

**Author:** ![marcopalacio](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marcopalacio/32/7677_2.png) [@marcopalacio](https://forum.mautic.org/u/marcopalacio)\
**Post date:** [May 31, 2022, 8:20pm UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294/3 "2022-05-31T20:20:20Z")

</div>

Do a fresh install of mautic and use the database from the previous version.

I just got into Mautic and now it works…

I did absolutely nothing and it works

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [June 1, 2022, 8:14am UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294/4 "2022-06-01T08:14:28Z")

</div>

Exactly, so your update may have failed to complete the required database upgrades, I’m guessing, causing the errors.

You’ll likely get some problems if you don’t rectify that problem and bring your database up to date, so you’re advised to follow the upgrade failed steps to update your database.

---

<div class="post-metadata">

**Author:** ![marcopalacio](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marcopalacio/32/7677_2.png) [@marcopalacio](https://forum.mautic.org/u/marcopalacio)\
**Post date:** [June 1, 2022, 12:24pm UTC](https://forum.mautic.org/t/tags-segments-or-landing-page-the-page-loads-and-stays-where-it-was-v4-3-1/24294/5 "2022-06-01T12:24:50Z")

</div>

I followed the indicated process and the following appears when updating the database

![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/d/d86cc0d825f85ab0deb785339d5d6834f6c3810b.png)
