# The site is currently offline due to encountering an error.

**URL:** <https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196>\
**Category:** Product Support\
**Created:** [August 18, 2015, 6:08am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196 "2015-08-18T06:08:36Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [August 18, 2015, 6:08am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/1 "2015-08-18T06:08:36Z")

</div>

Hi, need help installing Mautic. Here’s what i did

1. Downloaded Mautic from mautic.org  
2. uploaded to ftp  
3. tried to use [mydomain.com/mautic](http://mydomain.com/mautic) and [mydomain.com/mautic/installer](http://mydomain.com/mautic/installer) but both didn’t work. I got the error as below. Where did I go wrong?  
  
  
  
The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

---

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [August 18, 2015, 6:08am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/2 "2015-08-18T06:08:36Z")

</div>

Hi, need help installing Mautic. Here’s what i did

1. Downloaded Mautic from [mautic.org](http://mautic.org)
2. uploaded to ftp
3. tried to use [mydomain.com/mautic](http://mydomain.com/mautic) and [mydomain.com/mautic/installer](http://mydomain.com/mautic/installer) but both didn’t work. I got the error as below. Where did I go wrong?

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

---

<div class="post-metadata">

**Author:** ![chad.windnagle](https://avatars.discourse-cdn.com/v4/letter/c/7feea3/32.png) [@chad.windnagle](https://forum.mautic.org/u/chad.windnagle)\
**Post date:** [August 18, 2015, 11:55am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/3 "2015-08-18T11:55:57Z")

</div>

Is the .htaccess file present and is mod\_rewrite enabled for your server?

---

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [August 19, 2015, 1:17am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/4 "2015-08-19T01:17:47Z")

</div>

Hi Chad, thanks for helping. I’m very bad at this so hope you’ll be a slightly patient with me. Okay, .htacccess is there within the folder. As for mod\_rewrite, how do I check that?

---

<div class="post-metadata">

**Author:** ![buckhornmktg](https://avatars.discourse-cdn.com/v4/letter/b/54ee81/32.png) [@buckhornmktg](https://forum.mautic.org/u/buckhornmktg)\
**Post date:** [August 19, 2015, 5:16am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/5 "2015-08-19T05:16:35Z")

</div>

Can you check the error logs and post the errors? I wish I could tell you where those are located, but that depends on how your server is configured (ask your web host).

It seems unlikely that is a mod-rewrite issue, because I think you would probably get a server generated 500 error not a Mautic generated error message. If you were to access [yourdomain.com/mautic/installer](http://yourdomain.com/mautic/installer) w/o mod\_rewrite enabled you would probably get a 404 error. Those error logs are probably the best shot we have at troubleshooting this issue, so ask your web host where those are, sometimes they are accessible through FTP (look in folders above your html root directory). Other times the only way to access them is using SSH.

You could also try uploading your files again as some of them may be missing or were corrupted. I would download Mautic again as well and upload the newly downloaded files.

It’s also possible your missing a php extension that Mautic needs or it can’t write to the server. Just very common suggestions, not sure if they will be helpful, so send the error log entries if you can.

---

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [August 19, 2015, 6:48am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/6 "2015-08-19T06:48:52Z")

</div>

I actually tried re-uploading but the error was still there. I have not tried downloading the file again though… I think I found the log file. I hope this is the correct one

[Mon Aug 17 00:25:11 2015] [warn] RSA server certificate CommonName (CN) `localhost’ does NOT match server name!?  
[Mon Aug 17 07:48:30 2015] [error] [client 14.192.208.50] File does not exist: /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic  
[Mon Aug 17 07:48:30 2015] [error] [client 14.192.208.50] File does not exist: /home/salesmalay/domains/sales-training-malaysia.com/public\_html/favicon.ico, referer: [http://sales-training-malaysia.com/mautic/installer](http://sales-training-malaysia.com/mautic/installer)  
[Mon Aug 17 12:09:47 2015] [error] [client 136.243.5.215] File does not exist: /home/salesmalay/domains/sales-training-malaysia.com/public\_html/robots.txt  
[Mon Aug 17 13:54:51 2015] [error] [client 14.192.208.50] exception ‘RuntimeException’ with message ‘Unable to create the cache directory (/home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/app/cache/prod)n’ in /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/app/bootstrap.php.cache:2587nStack trace:n#0 /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/app/bootstrap.php.cache(2548): Symfony\Component\HttpKernel\Kernel-\>buildContainer()n#1 /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/app/AppKernel.php(222): Symfony\Component\HttpKernel\Kernel-\>initializeContainer()n#2 /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/app/AppKernel.php(69): AppKernel-\>boot()n#3 /home/salesmalay/domains/sales-training-malaysia.com/public\_html/mautic/index.php(38): AppKernel-\>handle(Object(Symfony\Component\HttpFoundation\Request))n#4 {main}  
[Mon Aug 17 23:53:14 2015] [error] [client 123.125.71.45] File does not exist: /home/salesmalay/domains/sales-training-malaysia.com/public\_html/robots.txt

---

<div class="post-metadata">

**Author:** ![lewkowski](https://avatars.discourse-cdn.com/v4/letter/l/a87d85/32.png) [@lewkowski](https://forum.mautic.org/u/lewkowski)\
**Post date:** [August 19, 2015, 1:59pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/7 "2015-08-19T13:59:12Z")

</div>

I got the same problem trying to install on a Windows IIS server.

“The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.  
System administrators, check server logs for errors.”

---

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [August 26, 2015, 3:35am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/8 "2015-08-26T03:35:27Z")

</div>

Hi… can anyone help?

---

<div class="post-metadata">

**Author:** ![CristianoAP](https://avatars.discourse-cdn.com/v4/letter/c/b5a626/32.png) [@CristianoAP](https://forum.mautic.org/u/CristianoAP)\
**Post date:** [August 30, 2015, 4:13pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/9 "2015-08-30T16:13:42Z")

</div>

When I had this problem I realized that the problem is in the folder permissions. I ran the command “chown -R apache / path / of / mautic” and the problem was solved.

---

<div class="post-metadata">

**Author:** ![SalesNinja\_Kevan](https://avatars.discourse-cdn.com/v4/letter/s/a5b964/32.png) [@SalesNinja\_Kevan](https://forum.mautic.org/u/SalesNinja_Kevan)\
**Post date:** [September 7, 2015, 5:56am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/10 "2015-09-07T05:56:57Z")

</div>

Hi ChristianoAP, thanks for helping out. Okay if you could help me out a little here, how do I run that command?

---

<div class="post-metadata">

**Author:** ![jengalla](https://avatars.discourse-cdn.com/v4/letter/j/6a8cbe/32.png) [@jengalla](https://forum.mautic.org/u/jengalla)\
**Post date:** [December 1, 2015, 6:31am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/11 "2015-12-01T06:31:57Z")

</div>

any solution to this? I was able to complete installation but the error is still showing at the bottom of the page. I am able to log in but no functions are working…

---

<div class="post-metadata">

**Author:** ![dbhurley](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dbhurley/32/2_2.png) [@dbhurley](https://forum.mautic.org/u/dbhurley)\
**Post date:** [December 2, 2015, 3:01pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/12 "2015-12-02T15:01:44Z")

</div>

Your problem sounds somewhat different from the above thread as the issues you describe don’t sound like a complete site offline message due to permissions. Are you saying that your login screen loads and works successfully? If so then it sounds like you may have a different issue.

---

<div class="post-metadata">

**Author:** ![javier](https://avatars.discourse-cdn.com/v4/letter/j/9dc877/32.png) [@javier](https://forum.mautic.org/u/javier)\
**Post date:** [December 8, 2015, 8:06am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/13 "2015-12-08T08:06:28Z")

</div>

Same problem:

“The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.  
System administrators, check server logs for errors.”

MySQL Log error:

2015-12-07 23:01:01 17f4 InnoDB: Warning: Using innodb\_additional\_mem\_pool\_size is DEPRECATED. This option may be removed in future releases, together with the option innodb\_use\_sys\_malloc and with the InnoDB’s internal memory allocator.  
2015-12-07 23:01:01 6132 [Note] InnoDB: Using mutexes to ref count buffer pool pages  
2015-12-07 23:01:01 6132 [Note] InnoDB: The InnoDB memory heap is disabled  
2015-12-07 23:01:01 6132 [Note] InnoDB: Mutexes and rw\_locks use Windows interlocked functions  
2015-12-07 23:01:01 6132 [Note] InnoDB: Memory barrier is not used  
2015-12-07 23:01:01 6132 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2015-12-07 23:01:01 6132 [Note] InnoDB: Not using CPU crc32 instructions  
2015-12-07 23:01:01 6132 [Note] InnoDB: Initializing buffer pool, size = 16.0M  
2015-12-07 23:01:01 6132 [Note] InnoDB: Completed initialization of buffer pool  
2015-12-07 23:01:01 6132 [Note] InnoDB: Highest supported file format is Barracuda.  
2015-12-07 23:01:03 6132 [Note] InnoDB: 128 rollback segment(s) are active.  
2015-12-07 23:01:03 6132 [Note] InnoDB: Waiting for purge to start  
2015-12-07 23:01:03 6132 [Note] InnoDB: Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 5.6.26-74.0 started; log sequence number 1835047  
2015-12-07 23:01:03 6012 [Note] InnoDB: Dumping buffer pool(s) not yet started  
2015-12-07 23:01:04 6132 [Note] Plugin ‘FEEDBACK’ is disabled.  
2015-12-07 23:01:04 6132 [Note] Server socket created on IP: ‘::’.  
2015-12-07 23:01:06 6132 [Note] c:xamppmysqlbinmysqld.exe: ready for connections.  
Version: ‘10.1.9-MariaDB’ socket: ‘’ port: 3306 [mariadb.org](http://mariadb.org) binary distribution  
2015-12-07 23:03:34 3904 [Note] c:xamppmysqlbinmysqld.exe: Normal shutdown

2015-12-07 23:03:34 3904 [Note] Event Scheduler: Purging the queue. 0 events  
2015-12-07 23:03:34 6124 [Note] InnoDB: FTS optimize thread exiting.  
2015-12-07 23:03:34 3904 [Note] InnoDB: Starting shutdown…  
2015-12-07 23:03:36 3904 [Note] InnoDB: Shutdown completed; log sequence number 1835057  
2015-12-07 23:03:36 3904 [Note] c:xamppmysqlbinmysqld.exe: Shutdown complete

---

<div class="post-metadata">

**Author:** ![staormino](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@staormino](https://forum.mautic.org/u/staormino)\
**Post date:** [December 11, 2015, 9:03pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/14 "2015-12-11T21:03:48Z")

</div>

Yup, same issue here. I am able to login, but nothing is functioning. All I can do is login and log out.

---

<div class="post-metadata">

**Author:** ![dbhurley](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dbhurley/32/2_2.png) [@dbhurley](https://forum.mautic.org/u/dbhurley)\
**Post date:** [December 16, 2015, 3:58pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/15 "2015-12-16T15:58:31Z")

</div>

Do you have any output in the developer console within your browser?

---

<div class="post-metadata">

**Author:** ![blasharpie](https://avatars.discourse-cdn.com/v4/letter/b/c0e974/32.png) [@blasharpie](https://forum.mautic.org/u/blasharpie)\
**Post date:** [December 17, 2015, 1:58am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/16 "2015-12-17T01:58:03Z")

</div>

I am having the same issue “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator. System administrators, check server logs for errors.”

(BTW: If you give me clear step by step instructions on what I can get to help you, I would be more than happy to give you what ever you need)

* * *

FYI: Just before I got the error, I added a bounce back monitoring imap account and set the folders, then sent a email to a list of two email addresses, one of which creates a bounce.

Right now I am able to log in to Mautic but clicking on anything doesn’t seem to do anything

---

<div class="post-metadata">

**Author:** ![xofnot](https://avatars.discourse-cdn.com/v4/letter/x/35a633/32.png) [@xofnot](https://forum.mautic.org/u/xofnot)\
**Post date:** [December 17, 2015, 5:39am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/17 "2015-12-17T05:39:51Z")

</div>

this looks a bit the same as my problem. It was also when setting the bounce back monitoring imap account. Then I send a test mail from the configuration section - that email I received.

then I went into my emails section and send out a test mail for the email I was going to send out. It did not arrive, so I send it 2 or 3 times more.

after that i got the the site is currently offline dut to encountering an error.

in the log stats it says

PHP Notice: Undefined variable: pwrd in /mydomain/public\_html/mautic/app/config/local.php on line 106

when i go into the local.php file the real and full password is present at line 106

“password” =\> “fullpasword”  
),

if you tell me which info you need I can give you the output

---

<div class="post-metadata">

**Author:** ![vln104](https://avatars.discourse-cdn.com/v4/letter/v/5f9b8f/32.png) [@vln104](https://forum.mautic.org/u/vln104)\
**Post date:** [December 17, 2015, 2:22pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/18 "2015-12-17T14:22:21Z")

</div>

In case it is helpful to someone, I sometimes experience the mysterious “site is offline due to an error” error but there isn’t always a log. What I ended up doing is modify index.php to append the error message to the on screen generic error. It doesn’t solve the issue but should give clues to what the error is. Is there any reason we are hiding the message from the front end?

---

<div class="post-metadata">

**Author:** ![javier](https://avatars.discourse-cdn.com/v4/letter/j/9dc877/32.png) [@javier](https://forum.mautic.org/u/javier)\
**Post date:** [January 26, 2016, 5:52am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/19 "2016-01-26T05:52:25Z")

</div>

I finally installed it.

I found the error here “Bitnamimautic-1.2.3-0apache2logs” and it said:

“[2016-01-26 05:11:42] mautic.ERROR: Fatal: Maximum execution time of 120 seconds exceeded - in file C:Bitnamimautic-1.2.3-0appsmautichtdocsvendordoctrinedballibDoctrineDBALDriverPDOStatement.php - at line 35 [] []”

So I went to “C:Bitnamimautic-1.2.3-0php” opened php.ini with notepad (you must have visible extensions, other wise you won’t be able to see the file, and changed “max\_execution\_time = 300” it was on 30 sec before the change. Then restarted MySQL and Apache, and voila!!! is working perfect.

---

<div class="post-metadata">

**Author:** ![tiagorossi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tiagorossi/32/1420_2.png) [@tiagorossi](https://forum.mautic.org/u/tiagorossi)\
**Post date:** [April 23, 2016, 9:47pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196/20 "2016-04-23T21:47:17Z")

</div>

Just a follow up here, I’ve got this error today and after searching web I’ve not found a solution in other people posts.

My problem was I cant login but the links dont work, if I copy the link and put it into browser it works, very strange!

Then I’ve read the Mautic error file (error\_log), located at your Mautic folder, there I found:

```auto
 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/apc.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0
```

So, the APC module got this to not work, when installing Mautic I’ve updated the PHP version of the server and then APC are not working anymor because APC only work on that new version.

To fix I’ve logged via ssh and then did the command:

```auto
vi /usr/local/lib/php.ini
```

I’ve found the line:

```auto
extension="apc.so"
```

And commented:

```auto
;extension="apc.so"
```

Then I’ve restarted Apache and its working!

Hope it help someone.

[Next page](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/2196.md?page=2)
