# The site is currently offline due to encountering an error

**URL:** https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957
**Category:** Product Support
**Created:** [December 23, 2016, 10:23pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957 "2016-12-23T22:23:05Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)
#### Post date: [December 23, 2016, 10:23pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/1 "2016-12-23T22:23:05Z")

</div>

I am experiencing the following navigating to my Mautic (version 2.4 on PHP 5.6.29) installation:  
  
  
  
The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.  
  
System administrators, check server logs for errors.  
  
  
  
The following is reported in the error log:  
  
[23-Dec-2016 16:15:03 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:03 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:04 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:04 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:05 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:05 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Undefined offset: 0 in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2784  
  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 1980  
  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2786  
  
[23-Dec-2016 16:15:11 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:11 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Undefined offset: 0 in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2784  
  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 1980  
  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2786  
  
[23-Dec-2016 16:15:15 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:15 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:17 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:17 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:19 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:19 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:22 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:22 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:24 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:24 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:27 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:27 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:29 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:29 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:32 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:32 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
  
Module compiled with module API=20100525  
  
PHP compiled with module API=20131226  
  
These options need to match  
  
in Unknown on line 0  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
  
  
  
What do I have to do to resolve this issue?  
  
  
  
Thank you very much for your assistance.  
  
  
  
Best regards,  
  
  
  
Angelo.

---

<div class="post-metadata">

### Author: ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)
#### Post date: [December 23, 2016, 10:23pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/2 "2016-12-23T22:23:05Z")

</div>

I am experiencing the following navigating to my Mautic (version 2.4 on PHP 5.6.29) installation:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.  
System administrators, check server logs for errors.

The following is reported in the error log:  
[23-Dec-2016 16:15:03 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:03 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:04 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:04 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:05 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:05 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Undefined offset: 0 in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2784  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 1980  
[23-Dec-2016 16:15:07 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2786  
[23-Dec-2016 16:15:11 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:11 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Undefined offset: 0 in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2784  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 1980  
[23-Dec-2016 16:15:11 America/Chicago] PHP Notice: Trying to get property of non-object in /home/sgadmin/public\_html/components/com\_booklibrary/booklibrary.php on line 2786  
[23-Dec-2016 16:15:15 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:15 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:17 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:17 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:19 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:19 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:22 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:22 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:24 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:24 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:27 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:27 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:29 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:29 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:32 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:32 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:36 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module  
Module compiled with module API=20100525  
PHP compiled with module API=20131226  
These options need to match  
in Unknown on line 0  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119  
[23-Dec-2016 16:15:37 America/Chicago] PHP Notice: Undefined index: HTTP\_USER\_AGENT in /home/sgadmin/public\_html/plugins/system/t3/includes/core/less.php on line 119

What do I have to do to resolve this issue?

Thank you very much for your assistance.

Best regards,

Angelo.

---

<div class="post-metadata">

### Author: ![patrykkalinowski](https://avatars.discourse-cdn.com/v4/letter/p/a6a055/32.png) [@patrykkalinowski](https://forum.mautic.org/u/patrykkalinowski)
#### Post date: [December 23, 2016, 11:53pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/3 "2016-12-23T23:53:18Z")

</div>

It seems like you don’t have imagemagick package on your server.  
Try this:

```auto
sudo apt install imagemagick
```

---

<div class="post-metadata">

### Author: ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)
#### Post date: [December 24, 2016, 10:05pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/4 "2016-12-24T22:05:37Z")

</div>

I checked with my hosting service provider and we confirmed that ImageMagick is installed by default. I have upgraded to PHP5.6.29 as well and adjust the php.ini file to match. We even tried with PHP7.0. All rendered the same error message.

I have noticed the following in the error\_log file in the Mautic installed folder:  
[24-Dec-2016 20:50:06 UTC] exception ‘SymfonyComponentDependencyInjectionExceptionInvalidArgumentException’ with message ‘The parameter “debug.error\_handler.throw\_at” must be defined.’ in /home/sgadmin/public\_html/eme/app/cache/prod/appProdProjectContainer.php:3510  
Stack trace:  
#0 /home/sgadmin/public\_html/eme/vendor/symfony/framework-bundle/FrameworkBundle.php(52): appProdProjectContainer-\>getParameter(‘debug.error\_han…’)  
#1 /home/sgadmin/public\_html/eme/app/AppKernel.php(262): SymfonyBundleFrameworkBundleFrameworkBundle-\>boot()  
#2 /home/sgadmin/public\_html/eme/app/AppKernel.php(109): AppKernel-\>boot()  
#3 /home/sgadmin/public\_html/eme/app/middlewares/CORSMiddleware.php(92): AppKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#4 /home/sgadmin/public\_html/eme/app/middlewares/CatchExceptionMiddleware.php(44): MauticMiddlewareCORSMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#5 /home/sgadmin/public\_html/eme/app/middlewares/VersionCheckMiddleware.php(57): MauticMiddlewareCatchExceptionMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#6 /home/sgadmin/public\_html/eme/vendor/stack/builder/src/Stack/StackedHttpKernel.php(23): MauticMiddlewareVersionCheckMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#7 /home/sgadmin/public\_html/eme/vendor/stack/run/src/Stack/run.php(13): StackStackedHttpKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest))  
#8 /home/sgadmin/public\_html/eme/index.php(32): Stackrun(Object(StackStackedHttpKernel))  
#9 {main}  
[24-Dec-2016 20:50:16 UTC] exception ‘SymfonyComponentDependencyInjectionExceptionInvalidArgumentException’ with message ‘The parameter “debug.error\_handler.throw\_at” must be defined.’ in /home/sgadmin/public\_html/eme/app/cache/prod/appProdProjectContainer.php:3510  
Stack trace:  
#0 /home/sgadmin/public\_html/eme/vendor/symfony/framework-bundle/FrameworkBundle.php(52): appProdProjectContainer-\>getParameter(‘debug.error\_han…’)  
#1 /home/sgadmin/public\_html/eme/app/AppKernel.php(262): SymfonyBundleFrameworkBundleFrameworkBundle-\>boot()  
#2 /home/sgadmin/public\_html/eme/app/AppKernel.php(109): AppKernel-\>boot()  
#3 /home/sgadmin/public\_html/eme/app/middlewares/CORSMiddleware.php(92): AppKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#4 /home/sgadmin/public\_html/eme/app/middlewares/CatchExceptionMiddleware.php(44): MauticMiddlewareCORSMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#5 /home/sgadmin/public\_html/eme/app/middlewares/VersionCheckMiddleware.php(57): MauticMiddlewareCatchExceptionMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#6 /home/sgadmin/public\_html/eme/vendor/stack/builder/src/Stack/StackedHttpKernel.php(23): MauticMiddlewareVersionCheckMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#7 /home/sgadmin/public\_html/eme/vendor/stack/run/src/Stack/run.php(13): StackStackedHttpKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest))  
#8 /home/sgadmin/public\_html/eme/index.php(32): Stackrun(Object(StackStackedHttpKernel))  
#9 {main}  
[24-Dec-2016 20:58:30 UTC] exception ‘SymfonyComponentDependencyInjectionExceptionInvalidArgumentException’ with message ‘The parameter “debug.error\_handler.throw\_at” must be defined.’ in /home/sgadmin/public\_html/eme/app/cache/prod/appProdProjectContainer.php:3510  
Stack trace:  
#0 /home/sgadmin/public\_html/eme/vendor/symfony/framework-bundle/FrameworkBundle.php(52): appProdProjectContainer-\>getParameter(‘debug.error\_han…’)  
#1 /home/sgadmin/public\_html/eme/app/AppKernel.php(262): SymfonyBundleFrameworkBundleFrameworkBundle-\>boot()  
#2 /home/sgadmin/public\_html/eme/app/AppKernel.php(109): AppKernel-\>boot()  
#3 /home/sgadmin/public\_html/eme/app/middlewares/CORSMiddleware.php(92): AppKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#4 /home/sgadmin/public\_html/eme/app/middlewares/CatchExceptionMiddleware.php(44): MauticMiddlewareCORSMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#5 /home/sgadmin/public\_html/eme/app/middlewares/VersionCheckMiddleware.php(57): MauticMiddlewareCatchExceptionMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#6 /home/sgadmin/public\_html/eme/vendor/stack/builder/src/Stack/StackedHttpKernel.php(23): MauticMiddlewareVersionCheckMiddleware-\>handle(Object(SymfonyComponentHttpFoundationRequest), 1, true)  
#7 /home/sgadmin/public\_html/eme/vendor/stack/run/src/Stack/run.php(13): StackStackedHttpKernel-\>handle(Object(SymfonyComponentHttpFoundationRequest))  
#8 /home/sgadmin/public\_html/eme/index.php(32): Stackrun(Object(StackStackedHttpKernel))  
#9 {main}

---

<div class="post-metadata">

### Author: ![mucky](https://avatars.discourse-cdn.com/v4/letter/m/a88e57/32.png) [@mucky](https://forum.mautic.org/u/mucky)
#### Post date: [December 25, 2016, 1:27am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/5 "2016-12-25T01:27:00Z")

</div>

Had this issue yesterday when installing Mautic 2.4.0. The directory and files within the mautic installation were owned by root. I changed the ownership to my own user and the error is now gone.

---

<div class="post-metadata">

### Author: ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)
#### Post date: [December 27, 2016, 7:53pm UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/6 "2016-12-27T19:53:28Z")

</div>

In my case the user is set to my hosting account user. We did also run a permfix, however, this has not changed the situation. Still getting the same error message. Even flushed the browser cache and tried again. Issue is still persisting.

---

<div class="post-metadata">

### Author: ![Salvador](https://avatars.discourse-cdn.com/v4/letter/s/4da419/32.png) [@Salvador](https://forum.mautic.org/u/Salvador)
#### Post date: [August 22, 2017, 5:07am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/7 "2017-08-22T05:07:58Z")

</div>

I’m facing the same problem people

---

<div class="post-metadata">

### Author: ![theatereleven](https://avatars.discourse-cdn.com/v4/letter/t/85e7bf/32.png) [@theatereleven](https://forum.mautic.org/u/theatereleven)
#### Post date: [November 29, 2017, 2:24am UTC](https://forum.mautic.org/t/the-site-is-currently-offline-due-to-encountering-an-error/6957/8 "2017-11-29T02:24:41Z")

</div>

@Salvador - assuming you got this fixed, but for anyone else:

I ran into this today on a clean install of Debian 9 / MariaDB / PHP 7 / Nginx.

Turns out, I was missing PHP XML (apt-get install php-xml). The error was identified in my site’s log files.
