# Unable to Open Certain Contact Cards

**URL:** <https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156>\
**Category:** Product Support\
**Created:** [February 14, 2021, 1:39pm UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156 "2021-02-14T13:39:22Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [February 14, 2021, 1:39pm UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156/1 "2021-02-14T13:39:22Z")

</div>

**Your software**  
My Mautic version is: 3.2.5  
My PHP version is: 7.2.24  
My Database type and version is: 10.2.31-MariaDB

**Your problem**  
My problem is:

When trying to access a specific contact card I am unable to view the details.

These errors are showing in the log:

2021/02/14 13:35:26 [error] 25803#25803: \*60686 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicContentBundle/Views/SubscribedEvents/Timeline/index.html.php on line 11  
PHP message: PHP Notice: Undefined index: log in /var/www/mautic/app/bundles/DynamicConte  
2021/02/14 13:35:26 [error] 25803#25803: \*60686 upstream sent too big header while reading response header from upstream, client: 84.228.126.65, server: [domain.com](http://domain.com), request: “GET /s/contacts/view/9978?\_=1613309356556&mauticUserLastActive=370&mauticLastNotificationId= HTTP/2.0”, upstream: “fastcgi://unix:/run/php/php7.2-fpm.sock:”, host: "[domain.com](http://domain.com), referrer: “[https://domain.com/s/contacts](https://domain.com/s/contacts)”

Steps I have tried to fix the problem:

Deleted /var/cache/prod  
chown -R www-data:www-data /mautic/\*  
Updated DB schema /s/update/schema

---

<div class="post-metadata">

**Author:** ![dimitri](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dimitri/32/4437_2.png) [@dimitri](https://forum.mautic.org/u/dimitri)\
**Post date:** [February 15, 2021, 3:59pm UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156/2 "2021-02-15T15:59:40Z")

</div>

Did this happen directly after an update?

Other things you can try:

Download Mautic, the same version, and use FTP to manually upload all the files again. Just to make sure that all the files are available and not corrupted.

Look not only at file ownership, but also file rights: [File ownership and permissions | Mautic Community Documentation](https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions)

Log out of the Mautic interface, delete your cookies.

Delete the cache again.

And login again.

After doing the above there is not much more left I can think of.

---

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [February 16, 2021, 7:43am UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156/3 "2021-02-16T07:43:11Z")

</div>

Hi  
Thanks for the suggestions. Unfortunately this did not work after following all steps.

Very strange behaviours indeed.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [February 17, 2021, 9:58am UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156/4 "2021-02-17T09:58:24Z")

</div>

> [@mikew](#):
>
> upstream sent too big header while reading response header from upstream

Hey Mike,  
Did you see this article about the upstream header size issue your logs contain?

> **[Resolved - NGINX error: upstream sent too big header](https://talk.plesk.com/threads/nginx-error-upstream-sent-too-big-header.338232/)**
>
> Hello everybody,
> 
> we receive errors during working with WordPress installations on our server:
> 
> 84381#0: \*2908 upstream sent too big header while reading response header from upstream
> 
> Sometimes when updating plugins, but also when just clicking...

---

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [February 17, 2021, 12:19pm UTC](https://forum.mautic.org/t/unable-to-open-certain-contact-cards/18156/5 "2021-02-17T12:19:01Z")

</div>

Hey @joeyk thanks for the link. I have not come across this one as of yet, I have gone through it, however I am a bit confused as to where to add the amendments:

* * *

"But finally I resolved my upstream problem not with changing the fastcgi settings but with changing it to exactly this settings:

proxy\_buffering on;  
proxy\_buffer\_size 128k;  
proxy\_buffers 4 256k;  
proxy\_busy\_buffers\_size 256k;

I created a .conf file just for this and in /etc/nginx/conf.d"

* * *

Should I update this in the mautic.conf file, and if so any idea as where about to add it?
