# Update 1.2.1 failed, mautic does not work, help

**URL:** <https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620>\
**Category:** Product Support\
**Created:** [October 26, 2015, 4:45pm UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620 "2015-10-26T16:45:50Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![xofnot](https://avatars.discourse-cdn.com/v4/letter/x/35a633/32.png) [@xofnot](https://forum.mautic.org/u/xofnot)\
**Post date:** [October 26, 2015, 4:45pm UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/1 "2015-10-26T16:45:50Z")

</div>

update 1.2.1 failed, mautic does not start up.  
  
  
  
i get a 500 error.  
  
  
  
the upgrade file says  
  
  
  
Could not move file /vendor/willdurand/oauth-server-bundle/DependencyInjection/Security/Factory/OAuthFactory.php to production.  
  
Could not move file /vendor/willdurand/oauth-server-bundle/Model/RequestToken.php to production.  
  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/model/Consumer.orm.xml to production.  
  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/model/RequestToken.orm.xml to production.  
  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/orm.xml to production.  
  
Could not move files from /vendor/willdurand/oauth-server-bundle/Service to production since the folder could not be created.  
  
Failed to remove the upgrade directory /vendor/willdurand folder  
  
Could not move file /vendor/autoload.php to production.  
  
Failed to remove the upgrade directory /vendor folderCould not remove the application cache. You will need to manually delete /data/sites/web/mysite/www/EMM/app/cache/prod.pg  
  
  
  
when i try to manually do the upgrade I get  
  
  
  
{“complete”:false,“error”:true,“updateState”:“eyJwbHVnaW5Db21wbGV0ZSI6ZmFsc2UsImJ1bmRsZUNvbXBsZXRlIjpmYWxzZSwiY2FjaGVDb21wbGV0ZSI6ZmFsc2UsImNvcmVDb21wbGV0ZSI6ZmFsc2UsInZlbmRvckNvbXBsZXRlIjpmYWxzZX0=”,“stepStatus”:“Failed”,“message”:“Invalid task”}

---

<div class="post-metadata">

**Author:** ![xofnot](https://avatars.discourse-cdn.com/v4/letter/x/35a633/32.png) [@xofnot](https://forum.mautic.org/u/xofnot)\
**Post date:** [October 26, 2015, 4:45pm UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/2 "2015-10-26T16:45:50Z")

</div>

update 1.2.1 failed, mautic does not start up.

i get a 500 error.

the upgrade file says

Could not move file /vendor/willdurand/oauth-server-bundle/DependencyInjection/Security/Factory/OAuthFactory.php to production.  
Could not move file /vendor/willdurand/oauth-server-bundle/Model/RequestToken.php to production.  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/model/Consumer.orm.xml to production.  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/model/RequestToken.orm.xml to production.  
Could not move file /vendor/willdurand/oauth-server-bundle/Resources/config/orm.xml to production.  
Could not move files from /vendor/willdurand/oauth-server-bundle/Service to production since the folder could not be created.  
Failed to remove the upgrade directory /vendor/willdurand folder  
Could not move file /vendor/autoload.php to production.  
Failed to remove the upgrade directory /vendor folderCould not remove the application cache. You will need to manually delete /data/sites/web/mysite/www/EMM/app/cache/prod.pg

when i try to manually do the upgrade I get

{“complete”:false,“error”:true,“updateState”:“eyJwbHVnaW5Db21wbGV0ZSI6ZmFsc2UsImJ1bmRsZUNvbXBsZXRlIjpmYWxzZSwiY2FjaGVDb21wbGV0ZSI6ZmFsc2UsImNvcmVDb21wbGV0ZSI6ZmFsc2UsInZlbmRvckNvbXBsZXRlIjpmYWxzZX0=”,“stepStatus”:“Failed”,“message”:“Invalid task”}

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [October 26, 2015, 5:49pm UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/3 "2015-10-26T17:49:34Z")

</div>

Check the file permissions. It seems that Mautic doesn’t have rights to move and delete those files. After that, check [http://johnlinhart.com/blog/uh-oh-mautic-upgrade-was-not-successful](http://johnlinhart.com/blog/uh-oh-mautic-upgrade-was-not-successful)

---

<div class="post-metadata">

**Author:** ![xofnot](https://avatars.discourse-cdn.com/v4/letter/x/35a633/32.png) [@xofnot](https://forum.mautic.org/u/xofnot)\
**Post date:** [October 31, 2015, 11:09am UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/4 "2015-10-31T11:09:18Z")

</div>

thank you, i went back to 1.2.0 and it works again

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [November 2, 2015, 10:11am UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/5 "2015-11-02T10:11:03Z")

</div>

That’s not good. Latest versions adds new features and fixes a bunch of bugs. It’d be better for you to fix the problem.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:57pm UTC](https://forum.mautic.org/t/update-1-2-1-failed-mautic-does-not-work-help/2620/6 "2020-02-02T22:57:24Z")

</div>


