# Update to 2.16 failed - out of memory exception

**URL:** <https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876>\
**Category:** Product Support\
**Created:** [February 18, 2020, 3:49pm UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876 "2020-02-18T15:49:03Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![michaloptingo](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/michaloptingo/32/422_2.png) [@michaloptingo](https://forum.mautic.org/u/michaloptingo)\
**Post date:** [February 18, 2020, 3:49pm UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876/1 "2020-02-18T15:49:03Z")

</div>

**Your software**  
My Mautic version is:2.15.3  
My PHP version is:7.2

**Your problem**  
My problem is:  
Upgrading to 2.16 via SSH (console mautic:upgrade:apply) and getting memory exception error.  
PHP info shows memory\_limit 8192M

These errors are showing in the log:

[Symfony\Component\Debug\Exception\OutOfMemoryException]  
Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 50261216 bytes)

any hints?

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 18, 2020, 9:16pm UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876/2 "2020-02-18T21:16:42Z")

</div>

Hi there, welcome back to the forums!

Sorry to hear you’re encountering problems.

Please can you also check the memory limit for CLI?

Use `php -i` to find out which php.ini file it is loading on the CLI and set your `memory_limit` there. It is likely to be a different location to what is used for regular php, but depends on how your server is set up.

---

<div class="post-metadata">

**Author:** ![michaloptingo](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/michaloptingo/32/422_2.png) [@michaloptingo](https://forum.mautic.org/u/michaloptingo)\
**Post date:** [February 19, 2020, 10:24am UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876/3 "2020-02-19T10:24:10Z")

</div>

Hi,

your post enlightened me - do not know why I have not checked that 🙂  
You were right - I was setting bigger PHP limit for apache but have not realised its still too low for PHP run from command line 🙂

So all solved now!

Great thanks!

Best regards,

Michal

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 19, 2020, 10:29am UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876/4 "2020-02-19T10:29:53Z")

</div>

Fantastic, glad to hear it! This caught me out so many times so I always look for that as soon as I’m hitting those errors at command line!

---

<div class="post-metadata">

**Author:** ![ekke](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ekke/32/296_2.png) [@ekke](https://forum.mautic.org/u/ekke)\
**Post date:** [February 20, 2020, 8:17am UTC](https://forum.mautic.org/t/update-to-2-16-failed-out-of-memory-exception/12876/5 "2020-02-20T08:17:22Z")

</div>


