# Update = Unknown column l.6 in where clause

**URL:** <https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748>\
**Category:** General Discussion\
**Created:** [April 15, 2015, 7:24am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748 "2015-04-15T07:24:24Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![tristanbailey](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tristanbailey/32/9_2.png) [@tristanbailey](https://forum.mautic.org/u/tristanbailey)\
**Post date:** [April 15, 2015, 7:24am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/1 "2015-04-15T07:24:24Z")

</div>

Just clicked the button to update to 1.0.2 and now the site has the site is offline page up.  
  
  
  
The logs suggest the db is dieing here:  
  
SELECT l.id FROM leads l WHERE l.6 = ?’ with params [“email”]  
  
  
  
Unknown column l.6 in where clause

---

<div class="post-metadata">

**Author:** ![tristanbailey](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tristanbailey/32/9_2.png) [@tristanbailey](https://forum.mautic.org/u/tristanbailey)\
**Post date:** [April 15, 2015, 7:24am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/2 "2015-04-15T07:24:24Z")

</div>

Just clicked the button to update to 1.0.2 and now the site has the site is offline page up.

The logs suggest the db is dieing here:  
SELECT l.id FROM leads l WHERE l.6 = ?’ with params [“email”]

Unknown column l.6 in where clause

---

<div class="post-metadata">

**Author:** ![tristanbailey](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tristanbailey/32/9_2.png) [@tristanbailey](https://forum.mautic.org/u/tristanbailey)\
**Post date:** [April 15, 2015, 7:30am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/3 "2015-04-15T07:30:13Z")

</div>

Sorry, that error seems to be an old one from logging visits this one is more fun error:

[Wed Apr 15 04:08:44.431788 2015] [:error] [pid 25470] [client 217.50.193.25:55490] exception ‘Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException’ with message ‘You have requested a non-existent parameter “mautic.max\_size”.’ in /var/www/html/clients/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php:106nStack trace:n#0 /var/www/html/clients/mautic/app/bootstrap.php.cache(1995): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag-\>get(‘mautic.max\_size’)n#1 /var/www/html/clients/mautic/app/config/config.php(200): Symfony\Component\DependencyInjection\Container-\>getParameter(‘mautic.max\_size’)n#2 /var/www/html/clients/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Loader/PhpFileLoader.php(39): include(’/var/www/html/c…’)n#3 /var/www/html/clients/mautic/vendor/symfony/config/Symfony/Component/Config/Loader/FileLoader.php(106): Symfony\Component\DependencyInjection\Loader\PhpFileLoader-\>load(’/var/www/html/c…’, NULL)n#4 /var/www/html/clients/mautic/app/config/config\_prod.php(2): Symfony\Component\Config\Loader\FileLoader-\>import(‘config.php’)n#5 /var/www/html/clients/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Loader/PhpFileLoader.php(39): include(’/var/www/html/c…’)n#6 /var/www/html/clients/mautic/vendor/symfony/config/Symfony/Component/Config/Loader/DelegatingLoader.php(45): Symfony\Component\DependencyInjection\Loader\PhpFileLoader-\>load(’/var/www/html/c…’, NULL)n#7 /var/www/html/clients/mautic/app/AppKernel.php(301): Symfony\Component\Config\Loader\DelegatingLoader-\>load(’/var/www/html/c…’)n#8 /var/www/html/clients/mautic/app/bootstrap.php.cache(2596): AppKernel-\>registerContainerConfiguration(Object(Symfony\Component\Config\Loader\DelegatingLoader))n#9 /var/www/html/clients/mautic/app/bootstrap.php.cache(2548): Symfony\Component\HttpKernel\Kernel-\>buildContainer()n#10 /var/www/html/clients/mautic/app/AppKernel.php(217): Symfony\Component\HttpKernel\Kernel-\>initializeContainer()n#11 /var/www/html/clients/mautic/app/AppKernel.php(74): AppKernel-\>boot()n#12 /var/www/html/clients/mautic/index.php(38): AppKernel-\>handle(Object(Symfony\Component\HttpFoundation\Request))n#13 {main}nnNext exception ‘Symfony\Component\Config\Exception\FileLoaderLoadException’ with message ‘Cannot load resource “/var/www/html/clients/mautic/app/config/config.php”. (You have requested a non-existent parameter “mautic.max\_size”.)’ in /var/www/html/clients/mautic/vendor/symfony/config/Symfony/Component/Config/Loader/FileLoader.php:120nStack trace:n#0 /var/www/html/clients/mautic/app/config/config\_prod.php(2): Symfony\Component\Config\Loader\FileLoader-\>import(‘config.php’)n#1 /var/www/html/clients/mautic/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Loader/PhpFileLoader.php(39): include(’/var/www/html/c…’)n#2 /var/www/html/clients/mautic/vendor/symfony/config/Symfony/Component/Config/Loader/DelegatingLoader.php(45): Symfony\Component\DependencyInjection\Loader\PhpFileLoader-\>load(’/var/www/html/c…’, NULL)n#3 /var/www/html/clients/mautic/app/AppKernel.php(301): Symfony\Component\Config\Loader\DelegatingLoader-\>load(’/var/www/html/c…’)n#4 /var/www/html/clients/mautic/app/bootstrap.php.cache(2596): AppKernel-\>registerContainerConfiguration(Object(Symfony\Component\Config\Loader\DelegatingLoader))n#5 /var/www/html/clients/mautic/app/bootstrap.php.cache(2548): Symfony\Component\HttpKernel\Kernel-\>buildContainer()n#6 /var/www/html/clients/mautic/app/AppKernel.php(217): Symfony\Component\HttpKernel\Kernel-\>initializeContainer()n#7 /var/www/html/clients/mautic/app/AppKernel.php(74): AppKernel-\>boot()n#8 /var/www/html/clients/mautic/index.php(38): AppKernel-\>handle(Object(Symfony\Component\HttpFoundation\Request))n#9 {main}

[Wed Apr 15 04:08:44.431965 2015] [:error] [pid 25470] [client 217.50.193.25:55490] PHP Notice: Undefined index: asset\_prefix in /var/www/html/clients/mautic/offline.php on line 10

---

<div class="post-metadata">

**Author:** ![tristanbailey](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tristanbailey/32/9_2.png) [@tristanbailey](https://forum.mautic.org/u/tristanbailey)\
**Post date:** [April 15, 2015, 7:31am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/4 "2015-04-15T07:31:14Z")

</div>

I am not even sure where to start with that Symfony error, the offline one is probably fine

---

<div class="post-metadata">

**Author:** ![tristanbailey](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tristanbailey/32/9_2.png) [@tristanbailey](https://forum.mautic.org/u/tristanbailey)\
**Post date:** [April 15, 2015, 7:35am UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/5 "2015-04-15T07:35:42Z")

</div>

The lines before show cant read the config, as this seems to be root:root with no permissions  
/var/www/html/clients/mautic/addons/MauticSocialBundle/Config/config.php

[Wed Apr 15 04:08:44.393271 2015] [:error] [pid 25470] [client 217.50.193.25:55490] PHP Warning: include(/var/www/html/clients/mautic/addons/MauticEmailMarketingBundle/MauticEmailMarketingBundle.php): failed to open stream: Permission denied in /var/www/html/clients/mautic/vendor/composer/ClassLoader.php on line 412[Wed Apr 15 04:08:44.393331 2015] [:error] [pid 25470] [client 217.50.193.25:55490] PHP Warning: include(): Failed opening ‘/var/www/html/clients/mautic/addons/MauticEmailMarketingBundle/MauticEmailMarketingBundle.php’ for inclusion (include\_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/html/clients/mautic/vendor/composer/ClassLoader.php on line 412[Wed Apr 15 04:08:44.429547 2015] [:error] [pid 25470] [client 217.50.193.25:55490] PHP Warning: include(/var/www/html/clients/mautic/addons/MauticSocialBundle/Config/config.php): failed to open stream: Permission denied in /var/www/html/clients/mautic/app/config/config.php on line 37[Wed Apr 15 04:08:44.429590 2015] [:error] [pid 25470] [client 217.50.193.25:55490] PHP Warning: include(): Failed opening ‘/var/www/html/clients/mautic/addons/MauticSocialBundle/Config/config.php’ for inclusion (include\_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/html/clients/mautic/app/config/config.php on line 37

---

<div class="post-metadata">

**Author:** ![chad.windnagle](https://avatars.discourse-cdn.com/v4/letter/c/7feea3/32.png) [@chad.windnagle](https://forum.mautic.org/u/chad.windnagle)\
**Post date:** [April 15, 2015, 1:12pm UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/6 "2015-04-15T13:12:50Z")

</div>

Hi Tristan:

Can you try deleting the cache? Just delete app/cache directory and see what happens. It’s complaining about config files, which are highly cached in Symfony.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 11:00pm UTC](https://forum.mautic.org/t/update-unknown-column-l-6-in-where-clause/1748/7 "2020-02-02T23:00:22Z")

</div>


