# Upgrade Error From 2.16.2 to 3.x

**URL:** <https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663>\
**Category:** Mautic 3 - Install/Upgrade Support\
**Tags:** release\
**Created:** [June 6, 2020, 2:15am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663 "2020-06-06T02:15:49Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 6, 2020, 2:15am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/1 "2020-06-06T02:15:49Z")

</div>

**Your software**  
My Mautic version is: Somewhere between 2.16.2 and 3.x  
My PHP version is: 7.3

**Your problem**  
My problem is: On “clearing cache” step of upgrade process froze for about an hour.  
Nothing in Apache Logs-  
Nothing In Mautic Logs-  
Php Logs had hundreds of warnings and errors /vendor/composer/ClassLoader.php on line 444  
and [mautic-install-directory.com/vendor/symfony/http-kernel/Kernel.php](http://mautic-install-directory.com/vendor/symfony/http-kernel/Kernel.php) - at line 363

Attempting to clear cache via command line with -vvv option the following errors displayed

These errors are showing in the log:  
In ArrayNode.php line 303:  
[Symfony\Component\Config\Definition\Exception\InvalidConfigurationExceptio n]  
Unrecognized option “type” under “framework.cache.pools.api\_rate\_limiter  
\_cache”

accompanied by  
Steps I have tried to fix the problem: reviewed logs - searched google. Found reference:[https://github.com/symfony/symfony/issues/29036](https://github.com/symfony/symfony/issues/29036)

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [June 6, 2020, 8:54am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/2 "2020-06-06T08:54:14Z")

</div>

We have not yet released the upgrade script for Mautic 3, the beta is going to be released on 15th June.

Please see: [https://www.mautic.org/blog/community/update-mautic-3](https://www.mautic.org/blog/community/update-mautic-3)

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 6, 2020, 3:26pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/3 "2020-06-06T15:26:20Z")

</div>

![200](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/6/6f81853cf190bed4ad0c5ebf01ebe1c3fb6ac07c.gif)  
I love setting up a test environment and clicking a nonexistent upgrade link from the future

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [June 6, 2020, 4:29pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/4 "2020-06-06T16:29:10Z")

</div>

Hi there,

There is no need for sarcasm. Please take a moment to refresh on the [code of conduct](https://contribute.mautic.org/policies/code-of-conduct), particularly

> Exercise consideration and respect in your speech and actions.

I am simply pointing out that there has not been an upgrade path released for 3.x yet. If you clicked on some upgrade notification it would be helpful for us to know where that appeared and what your stability channel is set to, as that shouldn’t be presented as an option.

If you want to try out Mautic 3, you can do so by downloading the ZIP from [Download - Mautic Community](https://mautic.org/download) or our [GitHub releases page](https://github.com/mautic/mautic/releases), ~~or by cloning the repository and switching branch.~~

The upgrade process will be released in beta on the 15th June as 2.16.3 so until then, you should not be attempting to migrate unless you’re testing with @dennisameling who is writing the script, in which case it would be helpful to provide feedback on the GitHub issue or the Mautic 3 channel on Slack.

I’m sure that Dennis would value some testing support on the migration script when it’s ready, so if you’d like to be involved with helping us test the migration please do let us know!

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 6, 2020, 5:26pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/5 "2020-06-06T17:26:26Z")

</div>

@rcheesley  
The upgrade notification appeared in the notifications as per usual- on this instance the stability channel is set to beta. I did a fresh install of mautic 2.16 and set the stability channel. Logged Out- Logged back in a this happened

 ![InkedScreenshot_LI](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/d/db1d4b9772dc65e1770e32ac5db88a42906a010d.jpeg)

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 6, 2020, 5:29pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/6 "2020-06-06T17:29:13Z")

</div>

Happened on a fresh install and stability set to alpha as well

 ![Mautic Upgrade](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/9/9df0c64b8e1e650980f9f4950f699c18194329f0.png)

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [June 6, 2020, 5:39pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/7 "2020-06-06T17:39:05Z")

</div>

That may explain it then. Please set the channel to Stable, which is what it should be by default.

I’ll check with the product team to see if we can prevent the 3.x series being made available to 2.x users, my understanding was that it shouldn’t be an option so thanks for raising it.

Once the upgrade script is available on the 15th, you’ll be able to update to 2.16.3 if you wish to do so, and then migrate up to 3.0.

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [June 8, 2020, 9:01am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/8 "2020-06-08T09:01:48Z")

</div>

Hi @EJL,

You shouldn’t get any more update notifications now related to Mautic 3 when using 2.16.2 with update channel “beta”. @silavapi has disabled the 3.0.0-beta update notification. Thanks for reporting this.

If you’d like to help us test the Mautic 2 -\> 3 migration process; I’ve pretty much finished the migration script last night and need some testers 😊 it involves installing a custom 2.16.3-beta build, which includes a dedicated upgrade script for Mautic 3. Please find the steps for testing over here: [https://github.com/mautic/mautic/pull/8824](https://github.com/mautic/mautic/pull/8824)

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 9, 2020, 12:52pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/9 "2020-06-09T12:52:04Z")

</div>

Appreciate the feedback. When attempting to deploy a fresh instance of 3.0 I ran into blob size errors during the install. This is using the zip version via link provided. I’ll have to work through those errors before I can give feedback on 3.0

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 10, 2020, 2:53pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/10 "2020-06-10T14:53:01Z")

</div>

@dennisameling here is the error:

An error occurred while attempting to install the data: An exception occurred while executing ‘CREATE TABLE mleads (id BIGINT UNSIGNED AUTO\_INCREMENT NOT NULL, owner\_id INT UNSIGNED DEFAULT NULL, stage\_id INT UNSIGNED DEFAULT NULL, is\_published TINYINT(1) NOT NULL, date\_added DATETIME DEFAULT NULL, created\_by INT DEFAULT NULL, created\_by\_user VARCHAR(191) DEFAULT NULL, date\_modified DATETIME DEFAULT NULL, modified\_by INT DEFAULT NULL, modified\_by\_user VARCHAR(191) DEFAULT NULL, checked\_out DATETIME DEFAULT NULL, checked\_out\_by INT DEFAULT NULL, checked\_out\_by\_user VARCHAR(191) DEFAULT NULL, points INT NOT NULL, last\_active DATETIME DEFAULT NULL, internal LONGTEXT DEFAULT NULL COMMENT ‘(DC2Type:array)’, social\_cache LONGTEXT DEFAULT NULL COMMENT ‘(DC2Type:array)’, date\_identified DATETIME DEFAULT NULL, preferred\_profile\_image VARCHAR(191) DEFAULT NULL, title VARCHAR(191) DEFAULT NULL, firstname VARCHAR(191) DEFAULT NULL, lastname VARCHAR(191) DEFAULT NULL, company VARCHAR(191) DEFAULT NULL, position VARCHAR(191) DEFAULT NULL, email VARCHAR(191) DEFAULT NULL, phone VARCHAR(191) DEFAULT NULL, mobile VARCHAR(191) DEFAULT NULL, address1 VARCHAR(191) DEFAULT NULL, address2 VARCHAR(191) DEFAULT NULL, city VARCHAR(191) DEFAULT NULL, state VARCHAR(191) DEFAULT NULL, zipcode VARCHAR(191) DEFAULT NULL, timezone VARCHAR(191) DEFAULT NULL, country VARCHAR(191) DEFAULT NULL, fax VARCHAR(255) DEFAULT NULL, preferred\_locale VARCHAR(255) DEFAULT NULL, attribution\_date DATETIME DEFAULT NULL, attribution DOUBLE PRECISION DEFAULT NULL, website LONGTEXT DEFAULT NULL, facebook VARCHAR(255) DEFAULT NULL, foursquare VARCHAR(255) DEFAULT NULL, instagram VARCHAR(255) DEFAULT NULL, linkedin VARCHAR(255) DEFAULT NULL, skype VARCHAR(255) DEFAULT NULL, twitter VARCHAR(255) DEFAULT NULL, INDEX IDX\_D41A0F687E3C61F9 (owner\_id), INDEX IDX\_D41A0F682298D193 (stage\_id), INDEX mlead\_date\_added (date\_added), INDEX mdate\_identified (date\_identified), INDEX mtitle\_search (title), INDEX mfirstname\_search (firstname), INDEX mlastname\_search (lastname), INDEX mcompany\_search (company), INDEX mposition\_search (position), INDEX memail\_search (email), INDEX mmobile\_search (mobile), INDEX mphone\_search (phone), INDEX mpoints\_search (points), INDEX mfax\_search (fax), INDEX maddress1\_search (address1), INDEX maddress2\_search (address2), INDEX mcity\_search (city), INDEX mstate\_search (state), INDEX mzipcode\_search (zipcode), INDEX mcountry\_search (country), INDEX mpreferred\_locale\_search (preferred\_locale), INDEX mtimezone\_search (timezone), INDEX mlast\_active\_search (last\_active), INDEX mattribution\_date\_search (attribution\_date), INDEX mattribution\_search (attribution), INDEX mfacebook\_search (facebook), INDEX mfoursquare\_search (foursquare), INDEX minstagram\_search (instagram), INDEX mlinkedin\_search (linkedin), INDEX mskype\_search (skype), INDEX mtwitter\_search (twitter), INDEX mcontact\_attribution (attribution, attribution\_date), INDEX mdate\_added\_country\_index (date\_added, country), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8mb4 COLLATE `utf8mb4_unicode_ci` ENGINE = InnoDB ROW\_FORMAT = DYNAMIC’: SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large (\> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline.

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [June 15, 2020, 8:26am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/11 "2020-06-15T08:26:26Z")

</div>

@EJL Can you give a bit more context about your environment? Especially OS and MySQL/MariaDB version are important to know. Then we can try to reproduce. Thanks in advance!

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 15, 2020, 1:48pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/12 "2020-06-15T13:48:23Z")

</div>

10 CPU cores  
60 GB RAM  
1600 GB disk space (100% SSD)

Centos 7  
Plesk obsidian panel

Mariadb 10.1.45

Php: 7.3.18

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [June 15, 2020, 1:56pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/13 "2020-06-15T13:56:26Z")

</div>

Hi there, I found a resolved issue on Github here:

> <https://github.com/mautic/mautic/issues/8587>
>
> \## Bug Description
> Trying to complete the Database setup step of installation a…nd it fails.
> 
> | Q | A
> | --- | ---
> | Mautic version | 3.0.0 beta
> | PHP version | 7.3.16
> | MariaDB version | 10.1.44
>  
> \### Log errors
> An error occurred while attempting to add default data: An exception occurred while executing 'CREATE INDEX mx20a\_instagram\_search ON mx20a\_leads (instagram)': SQLSTATE\[42000\]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
> 
> I can see #8557 exists however that is against MySQL 5.6.

Seems to be the same issue - @dennisameling possibly worth bearing in mind?

The solution seemed to be for them:

> I am going to test by replacing all occurrences of ENGINE=InnoDB to ENGINE=MyISAM and retry installation

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [June 19, 2020, 11:15am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/14 "2020-06-19T11:15:17Z")

</div>

Just checked with MariaDB 10.1. Also getting the “row size too large” error:

> An error occurred while attempting to add default data: An exception occurred while executing ‘CREATE INDEX instagram\_search ON leads (instagram)’: SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

I ran `SHOW VARIABLES LIKE "innodb_version"` on the server and it returned `5.6.46-86.2`. So MariaDB 10.1 basically equals MySQL 5.6. For Mautic 3 you’ll need at least MySQL 5.7, so MariaDB 10.2 in this case. In the Mautic 3 upgrade script I currently check for MariaDB 10.1 or higher, but will change this to 10.2 or higher. **There is currently no check for DB version in place on new installations.**

Changed to MariaDB 10.2 and that version is returning `5.7.29` as the InnoDB version 👍 can install without problems on that version.

@EJL can you please confirm whether upgrading to MariaDB 10.2 **prior to upgrading** solves the issue for you?

Thanks for letting us know about this issue!

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [June 19, 2020, 11:47am UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/15 "2020-06-19T11:47:25Z")

</div>

Yes I can confirm I was unable to upgrade from 2.16 or perform a fresh install of 3.0 until Mariadb was upgraded (to 10.3 in my case)

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [June 19, 2020, 12:50pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/16 "2020-06-19T12:50:34Z")

</div>

Thanks for reporting back.

We have taken the following steps to improve MariaDB support:

- [Add MariaDB to our CI testing pipeline](https://github.com/mautic/mautic/pull/8930)
- [Check for MariaDB 10.2+ (instead of 10.1+) in the Mautic 3 upgrade script](https://github.com/mautic/mautic/issues/8931)
- [Check if you’re running a supported database version in the clean installation process](https://forum.mautic.org/t/include-database-version-test-in-installer/14872)

I will go ahead and close this topic now. If you came across any other issues, please feel free to let us know in a new topic 🙂

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [June 19, 2020, 12:50pm UTC](https://forum.mautic.org/t/upgrade-error-from-2-16-2-to-3-x/14663/17 "2020-06-19T12:50:53Z")

</div>


