# Upgrade from MAUTIC 4.4.11 --\> 5.0.2 problem

**URL:** <https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [January 22, 2024, 11:18am UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602 "2024-01-22T11:18:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![omert](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/omert/32/10732_2.png) [@omert](https://forum.mautic.org/u/omert)\
**Post date:** [January 22, 2024, 11:18am UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602/1 "2024-01-22T11:18:53Z")

</div>

**Your software**  
My Mautic version is: 5.0.2  
My PHP version is: 8.0.28  
My Database type and version is: MySQL 8.0.35

**Your problem**  
My problem is:  
After upgrade from 4.4.11 → 5.0.2 I’m getting red offline error message (see screenshot below) in the browser along with the ‘parameter x must be defined’ error(s) when running commands such as (doctrine:migrations:migrate) via CLI.  
I am currently running 4.4.11 again (restored from backup).

\*Had no problem upgrading from 2 → 3 and from 3 → 4 with all the intermediate stable version upgrades.

These errors are showing in the log:  
Seems like the major problem is the “2FXXXXX” is not defined.  
This is the ‘mailer\_dsn’ / AMAZON SES/ special character in password issue talked about here:

> <https://github.com/mautic/mautic/issues/13236>
>
> \### Mautic Version
> 
> 5.0.x series
> 
> \### PHP version
> 
> 8.1
> 
> \### What browsers are yo…u seeing the problem on?
> 
> Not relevant
> 
> \### What happened?
> 
> Updating from M4 to M5 the update script creates the \`mailer\_dsn\` config key for you.
> 
> There is a bug in converting special chars properly:
> 
> \- Given my Amazon SES password looks like this: \`sometring/SOMEotherSTRING\`.
> \- The update process/migration will transform it to: \`sometring&2FSOMEotherSTRING\`, i.e., \`urlencode\` it.
> 
> The resulting \`config/local.php\` holds now a faulty \`mailer\_dsn\`: 
> 
> \`\`\`php
> \<?php
> $parameters = array(
> // \[...\]
> 'mailer\_dsn' =\> '...://MYUSER:sometring%2FSOMEotherSTRING...',
> };
> \`\`\`
> 
> This will lead to the following critical PHP error:
> 
> \`\`\`
> $ php bin/console
> 
>                                                                                                                         
> \[WARNING\] Some commands could not be registered:                                                                       
>                                                                                                                         
> 
> In AppKernelProdContainer.php line 11284:
>                                                       
> The parameter "2FSOMEotherSTRING" must be defined.  
>                                                       
> \`\`\`
> 
> Or in the logs:
> 
> \`\`\`
> console.CRITICAL: An error occurred while using the console. Message: "The parameter "2FSOMEotherSTRING" must be defined." {"exception":"\[object\] (Symfony\\\\Component\\\\DependencyInjection\\\\Exception\\\\InvalidArgumentException(code: 0): The parameter \\"2FSOMEotherSTRING\\" must be defined. at /.../mautic/docroot/var/cache/prod/Container7PjiqWi/AppKernelProdContainer.php:11284)","message":"The parameter \\"2FSOMEotherSTRING\\" must be defined."} {"hostname":"mautic.local","pid":24898}
> \`\`\`
> 
> The single ampersand in the \`mailer\_dsn\` config key leads Mautic/Symfony to believe there is a parameter that is not defined, hence the error.
> 
> The hotfix after updating is commenting out the config key \`mailer\_dsn\` in \`local.php\` and re-configure your mailer.
> 
> \### How can we reproduce this issue?
> 
> 1. Use M4
> 2. Set up a email transport with a password that contains special chars that need urlencoding
> 3. Update to M5
> 4. run \`bin/console\` or try to access the dashboard.
> 5. Mautic should fail yielding the mentioned error message
> 
> \### Relevant log output
> 
> \_No response\_
> 
> \### Code of Conduct
> 
> \- \[X\] I confirm that I have read and agree to follow this project's Code of Conduct
> 
> \<br /\>\<hr\>
> Care about this issue? Want to get it resolved sooner? If you are a \<a href='https://www.mautic.org/become-a-member-of-mautic'\>member of Mautic\</a\>, you can add some funds to the \<a href='https://opencollective.com/mautic/projects/bounties'\>Bounties Project\</a\> so that the person who completes this task can claim those funds once it is merged by a member of the core team! Read the docs \<a href='https://contribute.mautic.org/product-team/mautic-bounty-programme'\>here.\</a\>

After commenting out ‘mailer\_dsn’ line the ‘is not defined’ error doesn’t appear when running console command such as ‘cache:clear’. But red ‘offline’ message still shows when browsing to Mautic via browser.

 ![mautic_screenshot](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/a/a0b97757addd2cc57865d557df8e10a2ab14c83d.png)

Steps I have tried to fix the problem:

- Commenting out ‘mailer\_dsn’ in local.php.

---

<div class="post-metadata">

**Author:** ![mollux](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mollux/32/10618_2.png) [@mollux](https://forum.mautic.org/u/mollux)\
**Post date:** [January 22, 2024, 11:33am UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602/2 "2024-01-22T11:33:11Z")

</div>

@omert did you clear the cache after commenting out that line?

Can you check the logs (Apache / PHP / Mautic) for any pointers?

Please don’t create alle separate forum topics and github issues for variants of the same issue. This makes it hard to track and poinpoint the same issue.

---

<div class="post-metadata">

**Author:** ![omert](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/omert/32/10732_2.png) [@omert](https://forum.mautic.org/u/omert)\
**Post date:** [January 22, 2024, 12:19pm UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602/3 "2024-01-22T12:19:18Z")

</div>

Yes. I cleared the cache (cache:clear) after commenting that line.  
Cache was cleared successfully but red “offline” message still shows in browser when surfing over to mautic.

---

<div class="post-metadata">

**Author:** ![mollux](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mollux/32/10618_2.png) [@mollux](https://forum.mautic.org/u/mollux)\
**Post date:** [January 22, 2024, 12:31pm UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602/4 "2024-01-22T12:31:18Z")

</div>

@omert

> [@mollux](#):
>
> Can you check the logs (Apache / PHP / Mautic) for any pointers?

can you try by removing the `var/cache/prod` folder?  
Sometimes the Symfony `cache:clear` command doesn’t have the foreseen result.

---

<div class="post-metadata">

**Author:** ![omert](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/omert/32/10732_2.png) [@omert](https://forum.mautic.org/u/omert)\
**Post date:** [January 22, 2024, 12:36pm UTC](https://forum.mautic.org/t/upgrade-from-mautic-4-4-11-5-0-2-problem/30602/5 "2024-01-22T12:36:27Z")

</div>

I tried something like that already the first time around when I upgraded from 4.4.10 → 5.0.1.  
It didn’t work then.  
I’m very much reluctant to upgrade again just to try it.
