# Upgrade M3: Forbidden You don't have permission to access this resource

**URL:** https://forum.mautic.org/t/upgrade-m3-forbidden-you-dont-have-permission-to-access-this-resource/14836
**Category:** Mautic 3 - Install/Upgrade Support
**Created:** [June 17, 2020, 8:56am UTC](https://forum.mautic.org/t/upgrade-m3-forbidden-you-dont-have-permission-to-access-this-resource/14836 "2020-06-17T08:56:36Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![pboisdenghien](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/pboisdenghien/32/1712_2.png) [@pboisdenghien](https://forum.mautic.org/u/pboisdenghien)
#### Post date: [June 17, 2020, 8:56am UTC](https://forum.mautic.org/t/upgrade-m3-forbidden-you-dont-have-permission-to-access-this-resource/14836/1 "2020-06-17T08:56:36Z")

</div>

From Beta 2.16.3 : i got error message Forbidden You don’t have permission to access this resource when i tried to upgrade to M3.

as i updated from 2.16.2 to 2.16.3 without ant issue, i do not understand !

Are they any changes to apply in permission rules ?

I am using last Bitnami image on top of aws

Thank’s in advance

---

<div class="post-metadata">

### Author: ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)
#### Post date: [June 17, 2020, 9:38am UTC](https://forum.mautic.org/t/upgrade-m3-forbidden-you-dont-have-permission-to-access-this-resource/14836/2 "2020-06-17T09:38:15Z")

</div>

Hi there,

We are unable to support you if you do not provide the information required in the post template.

Please edit your post.

Here is the template:

**Your software**  
_My PHP version is_ :  
_My MySQL/MariaDB version is_ (delete as applicable): MySQL/MariaDB version

**Updating/Installing Errors**  
_I am_ (delete as applicable): Installing / Updating  
_Upgrading/installing via_ (delete as applicable) : Web / Command Line

_These errors are showing in the installer_ :

_These errors are showing in the Mautic log_ :

_These errors are showing in the upgrade\_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path)_ :

**Your problem**  
_My problem is_ :

_Steps I have tried to fix the problem_ :

---

<div class="post-metadata">

### Author: ![pboisdenghien](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/pboisdenghien/32/1712_2.png) [@pboisdenghien](https://forum.mautic.org/u/pboisdenghien)
#### Post date: [June 19, 2020, 7:52am UTC](https://forum.mautic.org/t/upgrade-m3-forbidden-you-dont-have-permission-to-access-this-resource/14836/3 "2020-06-19T07:52:16Z")

</div>

Solved :slight\_smile

htaccess.conf  
1 / replace Require all denied by Require all granted  
2 / Reboot  
3 / upgrade to M3  
4 / back htaccess.conf to Require all denied  
5/ Reboot

- 
# Apache 2.4+
- 
- 

```
# Deny access via HTTP requests to all PHP files.

```

- 

```
<FilesMatch "\.php$">

```

- 

```
    **Require all denied**

```

- 

```
</FilesMatch>

```

- 

```
# Except those whitelisted bellow.

```

- 

```
<FilesMatch "^(index|index_dev|filemanager|upgrade)\.php$">

```

- 

```
    Require all granted

```

- 

```
</FilesMatch>

```

-
