# Upgraded to 2.16, and now it won't work on any contact uploads

**URL:** <https://forum.mautic.org/t/upgraded-to-2-16-and-now-it-wont-work-on-any-contact-uploads/15312>\
**Category:** Product Support\
**Tags:** community\
**Created:** [July 21, 2020, 2:41pm UTC](https://forum.mautic.org/t/upgraded-to-2-16-and-now-it-wont-work-on-any-contact-uploads/15312 "2020-07-21T14:41:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bjkroege13](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bjkroege13/32/2646_2.png) [@bjkroege13](https://forum.mautic.org/u/bjkroege13)\
**Post date:** [July 21, 2020, 2:41pm UTC](https://forum.mautic.org/t/upgraded-to-2-16-and-now-it-wont-work-on-any-contact-uploads/15312/1 "2020-07-21T14:41:31Z")

</div>

**Your software**  
My Mautic version is:2.16  
My PHP version is:7.0

**Your problem**  
My problem is:  
Can’t load contacts  
These errors are showing in the log:  
[2020-07-21 09:20:45] mautic.CRITICAL: Uncaught PHP Exception Doctrine\DBAL\Exception\DriverException: “An exception occurred while executing ‘SELECT m0\_.is\_published AS is\_published\_0, m0\_.date\_added AS date\_added\_1, m0\_.created\_by AS created\_by\_2, m0\_.created\_by\_user AS created\_by\_user\_3, m0\_.date\_modified AS date\_modified\_4, m0\_.modified\_by AS modified\_by\_5, m0\_.modified\_by\_user AS modified\_by\_user\_6, m0\_.checked\_out AS checked\_out\_7, m0\_.checked\_out\_by AS checked\_out\_by\_8, m0\_.checked\_out\_by\_user AS checked\_out\_by\_user\_9, m0\_.id AS id\_10, m0\_.username AS username\_11, m0\_.password AS password\_12, m0\_.first\_name AS first\_name\_13, m0\_.last\_name AS last\_name\_14, m0\_.email AS email\_15, m0\_.position AS position\_16, m0\_.timezone AS timezone\_17, m0\_.locale AS locale\_18, m0\_.last\_login AS last\_login\_19, m0\_.last\_active AS last\_active\_20, m0\_.online\_status AS online\_status\_21, m0\_.preferences AS preferences\_22, m0\_.signature AS signature\_23, m1\_.is\_published AS is\_published\_24, m1\_.date\_added AS date\_added\_25, m1\_.created\_by AS created\_by\_26, m1\_.created\_by\_user AS created\_by\_user\_27, m1\_.date\_modified AS date\_modified\_28, m1\_.modified\_by AS modified\_by\_29, m1\_.modified\_by\_user AS modified\_by\_user\_30, m1\_.checked\_out AS checked\_out\_31, m1\_.checked\_out\_by AS checked\_out\_by\_32, m1\_.checked\_out\_by\_user AS checked\_out\_by\_user\_33, m1\_.id AS id\_34, m1\_.name AS name\_35, m1\_.description AS description\_36, m1\_.is\_admin AS is\_admin\_37, m1\_.readable\_permissions AS readable\_permissions\_38, m0\_.role\_id AS role\_id\_39 FROM ma\_users m0\_ LEFT JOIN ma\_roles m1\_ ON m0\_.role\_id = m1\_.id WHERE (m0\_.username = ? OR m0\_.email = ?) AND m0\_.is\_published = ?’ with params [“bkroeger”, “bkroeger”, 1]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away” at /home/v7x72z6sq727/public\_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 115 {“exception”:"[object] (Doctrine\DBAL\Exception\DriverException(code: 0): An exception occurred while executing ‘SELECT m0\_.is\_published AS is\_published\_0, m0\_.date\_added AS date\_added\_1, m0\_.created\_by AS created\_by\_2, m0\_.created\_by\_user AS created\_by\_user\_3, m0\_.date\_modified AS date\_modified\_4, m0\_.modified\_by AS modified\_by\_5, m0\_.modified\_by\_user AS modified\_by\_user\_6, m0\_.checked\_out AS checked\_out\_7, m0\_.checked\_out\_by AS checked\_out\_by\_8, m0\_.checked\_out\_by\_user AS checked\_out\_by\_user\_9, m0\_.id AS id\_10, m0\_.username AS username\_11, m0\_.password AS password\_12, m0\_.first\_name AS first\_name\_13, m0\_.last\_name AS last\_name\_14, m0\_.email AS email\_15, m0\_.position AS position\_16, m0\_.timezone AS timezone\_17, m0\_.locale AS locale\_18, m0\_.last\_login AS last\_login\_19, m0\_.last\_active AS last\_active\_20, m0\_.online\_status AS online\_status\_21, m0\_.preferences AS preferences\_22, m0\_.signature AS signature\_23, m1\_.is\_published AS is\_published\_24, m1\_.date\_added AS date\_added\_25, m1\_.created\_by AS created\_by\_26, m1\_.created\_by\_user AS created\_by\_user\_27, m1\_.date\_modified AS date\_modified\_28, m1\_.modified\_by AS modified\_by\_29, m1\_.modified\_by\_user AS modified\_by\_user\_30, m1\_.checked\_out AS checked\_out\_31, m1\_.checked\_out\_by AS checked\_out\_by\_32, m1\_.checked\_out\_by\_user AS checked\_out\_by\_user\_33, m1\_.id AS id\_34, m1\_.name AS name\_35, m1\_.description AS description\_36, m1\_.is\_admin AS is\_admin\_37, m1\_.readable\_permissions AS readable\_permissions\_38, m0\_.role\_id AS role\_id\_39 FROM ma\_users m0\_ LEFT JOIN ma\_roles m1\_ ON m0\_.role\_id = m1\_.id WHERE (m0\_.username = ? OR m0\_.email = ?) AND m0\_.is\_published = ?’ with params [“bkroeger”, “bkroeger”, 1]:\n\nSQLSTATE[HY000]: General error: 2006 MySQL server has gone away at /home/v7x72z6sq727/public\_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:115, Doctrine\DBAL\Driver\PDOException(code: HY000): SQLSTATE[HY000]: General error: 2006 MySQL server has gone away at /home/v7x72z6sq727/public\_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php:107, PDOException(code: HY000): SQLSTATE[HY000]: General error: 2006 MySQL server has gone away at /home/v7x72z6sq727/public\_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php:105)"}   
[2020-07-21 09:22:06] mautic.ERROR: PHP Error: Maximum execution time of 30 seconds exceeded - in file /home/v7x72z6sq727/public\_html/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php - at line 725    
[2020-07-21 09:22:06] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Error: Maximum execution time of 30 seconds exceeded - in file /home/v7x72z6sq727/public\_html/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php - at line 725

Steps I have tried to fix the problem: I’ve monitored my resources and they’re not maxing out, I’ve increased the max upload time and increased memory limit to no avail.

---

<div class="post-metadata">

**Author:** ![codes9](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/codes9/32/682_2.png) [@codes9](https://forum.mautic.org/u/codes9)\
**Post date:** [October 30, 2020, 11:36am UTC](https://forum.mautic.org/t/upgraded-to-2-16-and-now-it-wont-work-on-any-contact-uploads/15312/2 "2020-10-30T11:36:20Z")

</div>

> [@bjkroege13](#):
>
> Maximum execution time of 30

Maximum execution time of 30 seems to be the issue here. If you’re managing the server you need to increase this. This has more to do with your WebServer setup than it with Mautic. The insertion of the data in the Database takes more than 30 Seconds in this case. The server only allows it to run for 30 Seconds before killing the action which leads to your error.
