# Upgraded to v3 and Cron Jobs stopped working

**URL:** <https://forum.mautic.org/t/upgraded-to-v3-and-cron-jobs-stopped-working/20748>\
**Category:** Product Support\
**Tags:** mautic-3\
**Created:** [September 5, 2021, 12:36pm UTC](https://forum.mautic.org/t/upgraded-to-v3-and-cron-jobs-stopped-working/20748 "2021-09-05T12:36:17Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![ascar](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ascar/32/5770_2.png) [@ascar](https://forum.mautic.org/u/ascar)\
**Post date:** [September 5, 2021, 12:36pm UTC](https://forum.mautic.org/t/upgraded-to-v3-and-cron-jobs-stopped-working/20748/1 "2021-09-05T12:36:17Z")

</div>

**Your software**  
My Mautic version is: 3.2.4  
My PHP version is: 7.3.28  
My Database type and version is: 5.7.33

**Cron Jobs Stopped Working**  
My problem is:  
I have been holding off on upgrading my Mautic from 2.16.5 to the current version for a few months.  
Now, I have completed upgrade without a hitch, I only had to change PHP version from 7.4 to 7.3.

After upgrade I edited the cron jobs - only replaced the ‘app’ everywhere with ‘bin’. Added a contact and sat waiting for the segment to update. Nothing happened.

These errors are showing in the log:

No errors in cron.log

Steps I have tried to fix the problem:

Tried to copy command from the cron log and run

`/usr/bin/php /var/www/www.mysite.com/scm/bin/console mautic:segments:update`

from command line and got the segment updated.

Is there a confirmed bug or some issue with workaround for this scenario?

**I SOLVED THIS ISSUE BY CHECKING MAUTIC DIRECTORY OWNERSHIP. UPGRADE TO 3.2.4 WAS DONE AS ROOT, SO WHEN THE SCRIPT FINISHED MAUTIC AND ALL SUBDIRECTORIES ENDED UP BEING OWNED BY ROOT. CHOWN TO WWW-DATA FIXED THE PROBLEM I WAS FACING.**
