# Upgrading to Mautic 3.2.0 fails because of unsupported Mysql version

**URL:** <https://forum.mautic.org/t/upgrading-to-mautic-3-2-0-fails-because-of-unsupported-mysql-version/17224>\
**Category:** Product Support\
**Created:** [December 1, 2020, 5:42am UTC](https://forum.mautic.org/t/upgrading-to-mautic-3-2-0-fails-because-of-unsupported-mysql-version/17224 "2020-12-01T05:42:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![crispyholiday](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/crispyholiday/32/757_2.png) [@crispyholiday](https://forum.mautic.org/u/crispyholiday)\
**Post date:** [December 1, 2020, 5:42am UTC](https://forum.mautic.org/t/upgrading-to-mautic-3-2-0-fails-because-of-unsupported-mysql-version/17224/1 "2020-12-01T05:42:32Z")

</div>

**Your software**  
My Mautic version is: 3.2.0  
My PHP version is: 7.3.24  
My Database type and version is: Mysql 8.0.20

**Your problem**  
My problem is: While trying to upgrade from Mautic 3.1.2 to 3.2.0, I’ve received an error in the log saying that my DB does not support generated columns, and is in too old of a version.  
I am using Mysql 8.0 (which I’ve understood is supported, was I wrong?)

These errors are showing in the log:  
Your database version (5.5) does not support generated columns. Upgrade at least to 5.7.14 and update `db_server_version` accordingly to get the speed improvements

Steps I have tried to fix the problem:

---

<div class="post-metadata">

**Author:** ![crispyholiday](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/crispyholiday/32/757_2.png) [@crispyholiday](https://forum.mautic.org/u/crispyholiday)\
**Post date:** [December 1, 2020, 6:37am UTC](https://forum.mautic.org/t/upgrading-to-mautic-3-2-0-fails-because-of-unsupported-mysql-version/17224/2 "2020-12-01T06:37:44Z")

</div>

The issue was resolved, thanks to [this Github issue](https://github.com/mautic/mautic/issues/9202#issuecomment-709468358)

Apparently, the `db_server_version` field in `local.php` file was set to 5.5 for some reason, instead of 8.0.20. Changing it correctly and clearing cache using `cache:clear` resolved the issue.

For those of you who see this topic and looking for step by step, here you go:

1. Using SSH, access `/your/mautic/path/appp/config/local.php` and find the `db_server_version` field.
2. If it states a wrong version, change it according to your real MySQL server version and save your changes.
3. run `php /your/mautic/path/bin/console cache:clear`
4. run `php /your/mautic/path/bin/console doctrine:migrations:migrate`

Mautic team, is there a reason this field is set to the wrong version of the DB? Should it be updated manually when installing a new mautic environment?
