# Upgrading to v4: no commands specified in "mautic:cache" namespace

**URL:** <https://forum.mautic.org/t/upgrading-to-v4-no-commands-specified-in-mautic-cache-namespace/29844>\
**Category:** Mautic 4 Install/Upgrade Support\
**Created:** [November 6, 2023, 12:24pm UTC](https://forum.mautic.org/t/upgrading-to-v4-no-commands-specified-in-mautic-cache-namespace/29844 "2023-11-06T12:24:24Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![uykusuz](https://avatars.discourse-cdn.com/v4/letter/u/7feea3/32.png) [@uykusuz](https://forum.mautic.org/u/uykusuz)\
**Post date:** [November 6, 2023, 12:24pm UTC](https://forum.mautic.org/t/upgrading-to-v4-no-commands-specified-in-mautic-cache-namespace/29844/1 "2023-11-06T12:24:24Z")

</div>

Hi mautic community!

I’m in the process of upgrading mautic from v3 to v4 and have an issue. See the details below.

Can someone help me out and point me into the right direction?

Thank you in advance!

**Your software**

- _My PHP version is_ : 7.4.33
- _My MySQL version is_: 5.7.31
- using the [docker image for mautic](https://hub.docker.com/r/mautic/mautic/). Upgrading from v3 to v4 image tag

**Updating/Installing Errors**  
_I am_ : Updating  
_Upgrading via_: Command Line, docker

_These errors are showing in the Mautic log_ :

```auto
Ensuring Mautic database is present

MySQL Connection Error: (2002) Connection refused

Warning: mysqli::__construct(): (HY000/2002): Connection refused in /makedb.php on line 20

MySQL Database Created
========================================================================
This server is now configured to run Mautic!
The following information will be prefilled into the installer (keep password field empty):
Host Name: mautic-mysql-svc:3306
Database Name: mautic
Database Username: mautic
Database Password: <password>
========================================================================

========================================================================
Updating existing mautic config
========================================================================

  There are no commands defined in the "mautic:cache" namespace.

  Did you mean one of these?
      doctrine:cache
      mautic
      mautic:assets
      mautic:broadcasts
      mautic:campaigns
      mautic:citrix
      mautic:contacts
      mautic:email
      mautic:emails
      mautic:install
      mautic:integration
      mautic:integration:pipedrive
      mautic:integrations
      mautic:iplookup
      mautic:maintenance
      mautic:messages
      mautic:plugins
      mautic:queue
      mautic:reports
      mautic:segments
      mautic:social
      mautic:theme
      mautic:transifex
      mautic:translation
      mautic:unusedip
      mautic:update
      mautic:webhooks

```

**Your problem**  
_My problem is_ : the above error appears when I launch mautic using the v4 docker image.

_Steps I have tried to fix the problem_:  
Tried deleting the `/var/www/html/var/cache` directory.

_What did I actually do?_  
We have mautic v3 running, with the data directory coming from a volume mounted at `/var/www/html`. I did not find any guidelines how to upgrade from v3 to v4. So I figured I could do it by changing the image and hope mautic will try to figure things out. Changing the image to v4 and then launching mautic let’s that error appear.
