# What are working Monitored Inbox Settings for Mautic to Fetch Emails via IMAP?

**URL:** <https://forum.mautic.org/t/what-are-working-monitored-inbox-settings-for-mautic-to-fetch-emails-via-imap/10723>\
**Category:** Product Support\
**Created:** [August 24, 2018, 1:14pm UTC](https://forum.mautic.org/t/what-are-working-monitored-inbox-settings-for-mautic-to-fetch-emails-via-imap/10723 "2018-08-24T13:14:21Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![trialsmandan](https://avatars.discourse-cdn.com/v4/letter/t/d26b3c/32.png) [@trialsmandan](https://forum.mautic.org/u/trialsmandan)\
**Post date:** [August 24, 2018, 1:14pm UTC](https://forum.mautic.org/t/what-are-working-monitored-inbox-settings-for-mautic-to-fetch-emails-via-imap/10723/1 "2018-08-24T13:14:21Z")

</div>

Scenario: I set up a fresh Linux / Plesk VPS using Postfix / Dovecot, and of course Mautic. I want to use my own MTA / SMTP / IMAP services that are on the same server as where Mautic is installed. Not an outside service.

Mautic can send email. What it can’t do is Fetch email via IMAP.

I have tried essentially every conceivable combination of settings under ‘Monitored Inbox Settings’: localhost / 127.0.0.1 / actual IMAP URL; all possible ports (143, 993), all encryption options. No matter what, it will invariably fail with: Error communicating with the IMAP server: TLS/SSL failure for 127.0.0.1: SSL negotiation failed PHP Notice: Unknown: TLS/SSL failure for 127.0.0.1: SSL negotiation failed (errflg=2) in Unknown on line 0

or similar depending on the settings I am using at the moment. Obviously here I was using 127.0.0.1 for the IMAP URL. This error occurs even when Encryption is set to None.

I have not been able to find any useful information on this error, which is found in the Dovecot logs and is also the error logged by the CRON job mautic:email:fetch.

Obviously, the IMAP services work perfectly well from anywhere excepting Mautic.

Additional: On the rare occasions that clicking the test button results in ‘Success!’, the CRON job says ‘No mailboxes are configured’ even though there of course is a mailbox and password that it is using. And still no email is fetched.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [October 17, 2019, 4:33pm UTC](https://forum.mautic.org/t/what-are-working-monitored-inbox-settings-for-mautic-to-fetch-emails-via-imap/10723/2 "2019-10-17T16:33:12Z")

</div>


