# your script fails if nginx is installed using softaculous

**URL:** <https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965>\
**Category:** Product Support\
**Created:** [June 15, 2015, 12:17pm UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965 "2015-06-15T12:17:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mobilechipmunk](https://avatars.discourse-cdn.com/v4/letter/m/7ea924/32.png) [@mobilechipmunk](https://forum.mautic.org/u/mobilechipmunk)\
**Post date:** [June 15, 2015, 12:17pm UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965/1 "2015-06-15T12:17:48Z")

</div>

i’ve tried on 4 different servers with webuzo, cpanel, and plesk. if installed with softaculous and nginx is on server your app breaks.  
  
  
  
[http://dateverify.me/mautic/s/login](http://dateverify.me/mautic/s/login)

---

<div class="post-metadata">

**Author:** ![mobilechipmunk](https://avatars.discourse-cdn.com/v4/letter/m/7ea924/32.png) [@mobilechipmunk](https://forum.mautic.org/u/mobilechipmunk)\
**Post date:** [June 15, 2015, 12:17pm UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965/2 "2015-06-15T12:17:48Z")

</div>

i’ve tried on 4 different servers with webuzo, cpanel, and plesk. if installed with softaculous and nginx is on server your app breaks.

[http://dateverify.me/mautic/s/login](http://dateverify.me/mautic/s/login)

---

<div class="post-metadata">

**Author:** ![gmillard](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/gmillard/32/5_2.png) [@gmillard](https://forum.mautic.org/u/gmillard)\
**Post date:** [June 20, 2015, 6:51am UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965/3 "2015-06-20T06:51:11Z")

</div>

So nginx takes a little extra work to setup since out of the box, Symfony is built for use on Apache and uses .htaccess files.

Here’s an example nginx config file that may help:

[https://gist.github.com/drmmr763/747b9dc984faa58b6986](https://gist.github.com/drmmr763/747b9dc984faa58b6986)

You may also refer to [http://symfony.com/doc/current/cookbook/configuration/web\_server\_configuration.html#nginx](http://symfony.com/doc/current/cookbook/configuration/web_server_configuration.html#nginx) for some guidance.

Thanks!  
Alan

---

<div class="post-metadata">

**Author:** ![chad.windnagle](https://avatars.discourse-cdn.com/v4/letter/c/7feea3/32.png) [@chad.windnagle](https://forum.mautic.org/u/chad.windnagle)\
**Post date:** [June 22, 2015, 2:47pm UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965/4 "2015-06-22T14:47:17Z")

</div>

Hi Mobilechipmunk

Just to expand on what Alan said, the issue is that the .htaccess file doesn’t work on Nginx, so you have to create a config file which parses all content through the php index.php handler. This has to be done for any php application like Mautic (like wordpress or Joomla, etc…).

Chad

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:59pm UTC](https://forum.mautic.org/t/your-script-fails-if-nginx-is-installed-using-softaculous/1965/5 "2020-02-02T22:59:36Z")

</div>


