Error Updating from Mautic 3.2.0-rc -->3.2.1

Your software
My PHP version is :7.3
My MySQL/MariaDB version is : MariaDB version 10.5.8

Updating/Installing Errors
I am (delete as applicable): Updating
Upgrading/installing via (delete as applicable) : Command Line

These errors are showing in the installer :Step 2 Downloading update package…
PHP Notice: Undefined index: message in /var/www/vhosts/ on line 131
Here is line 131: > // Fetch the update package

        $package = $this->updateHelper->fetchPackage($update['package']);

        if (isset($package['error'])) {
            throw new UpdateFailedException($this->translator->trans($package['message']));

        return $this->pathsHelper->getCachePath().'/'.basename($update['package']);

Mautic Log: mautic.WARNING: Command mautic:update:apply exited with status code 1

These errors are showing in the Mautic log : mautic.WARNING: Command mautic:update:apply exited with status code 1

These errors are showing in the upgrade_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path) : None

Your problem
My problem is : Updates hang on step 2. I can see the zip file has been downloaded to mautic/var/cache/prod directory. File & Folder Permissions are good.

Steps I have tried to fix the problem : Read logs, restarted php , apache, nginx and mariadb

1 Like

Same here with a 3.2.0 stable … did you open an issue for that in Github as well?

No Sir I did not open an issue on github. If you did, I would appreciate a link so I can check it out

1 Like

Workaround: as its related to the package file, I downloaded and unzipped the filed while overwriting the existing ones. Refreshed cache and are now on 3.2.1.

Hope there weren’t any database migrations. But in this particular installation they are broken due to another bug anyway :roll_eyes:

1 Like

I tried your method again @dirk_s and ran doctrine:schema:update --env=prod --force and it worked. I upgraded to 3.2.1 and now 3.2.2 using this method. No issues so far

I’m facing this from 3.2.2 -> 3.2.4. Is this a bug?

This was documented in the release notes: Release Mautic Community 3.2.4 · mautic/mautic · GitHub

Quoted here for reference:

:warning: Important note for users who are currently running 3.2.0 or later

Are you currently using Mautic 3.2.0 or later and do you update through the CLI (Command Line Interface) ? Then the message below applies to you! This does not apply if you’re updating through the UI (graphical interface).

When you’re trying to update through the CLI, you might run into the following error:

Notice: Undefined index: message in /var/www/html/app/bundles/CoreBundle/Update/Step/InstallNewFilesStep.php on line 131

Failed to execute command php bin/console mautic:update:apply: exit status 1

This bug was introduced in Mautic 3.2.0 and fixed in 3.2.4. Please use the following workaround:

php bin/console mautic:update:apply
php bin/console mautic:update:apply --finish

See also: