Mautic 3 builder disabled

Current settings
PHP 7.3.20

Hi all!

I’ve updated my Mautic from 2.16.x to 3.0, then to 3.0.1 and I’m unable to edit or create any email in the builder.
I’ve tried to create new emails and edit them in the build with various templates and just code too but it simple don’t work, it is not editable, I just can exit the builder.

I’ve already changed the corn jobs to the new path, cleaned the cache, but don’t know what to do more to solve this!

Thanks for your help.


I am facing the same, any solution for this yet ?

Please update to the latest release, 3.1. We’re going to be shipping 3.1.1 this evening, so you may want to hold off until then :slight_smile:

I just upgraded, to mautic 3.0.1 actually customer for whom I manage mautic, Tried to upgrade by clicking notification bubble which in turn broke the upgrade because I was using Custom Plugins, which were of course not supported directly by Mautic 3.x.

I was able to upgrade with php upgrade_v3.php after disabling custom plugins.

My problem However I found out was directory permissions which I fixed. So my comment for this post is currently obsolete.

I would recommend anyone who facing issues is:

  1. Ensure you update console path, now it has moved to bin directory(since symfony has moved it there and with upgraded version of symfony) it makes sense.
  2. Ensure proper write permissions are given to php to be able to write in var/cache and var/logs directory. (This was my issue at first which on resolve i was able to know real issue through logs).

However now there is new issue, Forms are not working, as in I am not able to create new forms and logs says:

[2020-09-28 13:43:33] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalThrowableError: "Type error: Argument 1 passed to URLify::transliterate() must be of the type string, null given, called in /var/www/mautic/app/bundles/CoreBundle/Helper/InputHelper.php on line 516" at /var/www/mautic/vendor/jbroadway/urlify/URLify.php line 360 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Type error: Argument 1 passed to URLify::transliterate() must be of the type string, null given, called in /var/www/mautic/app/bundles/CoreBundle/Helper/InputHelper.php on line 516 at /var/www/mautic/vendor/jbroadway/urlify/URLify.php:360)"} []

which is no longer related to cache or directory permission issue but something else, which i am trying to figure.

There is a fix coming for this. It is likely because you have not got the intl PHP extension enabled.

PR is here:

We had to bump it from 3.1.1 due to a lack of testers.

1 Like

Thanks @rcheesley,

found it, and fixed it.

Thanks for your active support! Its been a while I was out of touch because of less work in Mautic, hopefully will get back in action soon and dig deeper in Mautic v3 features and issues.

Cheers to everyone contributing!

1 Like

Great, welcome back! Glad you got it sorted in the end :slight_smile: