5.0.1 -> 5.0.2 No longer able to open campaign builder

Your software
My Mautic version is: 5.0.2
My PHP version is: 8.1.26
My Database type and version is: MySQL 8.0.35

Your problem
My problem is: Since updating to 5.0.2 from 5.0.1, I have not been able to launch the campaign builder.


These errors are showing in the log:
I could not find any relevant logs, but I may not have been looking in the right place.

Steps I have tried to fix the problem:

  • Clear cache folder for the Mautic app.
  • Restart the server.
  • Create a new campaign to see if only existing campaigns are affected, but unable to open campaign builder of new campaigns as well.

Any ideas of what I can try? Thanks!

Hello @xavier_h

I would take some extra more steps to understand the problem:

  1. Clean your browser cache
  2. Check your browser console, and see if it has any errors.
  3. Check your error log system at Settings > System log > Log

Best regards,
Ricardo Freire

Hi @ricfreire !

Thank you for the reply and suggestions! I tried clearing the browser cache by deleting the cookies, session storage, and local storage. After hard refreshing, signing in, I am still unable to open the campaign builder. :thinking:

I do have some warnings and an error in the console related to being unable to fetch the avatar image. Not sure why it’s trying to get the image from the i2.wp.com domain.

Additionally, there do not seem to be any logs within System Info.

Many thanks!

@xavier_h two questions:

  • Are you using an Ad blocker or any Chrome extension related to it?
  • Did you set up your Mautic folder permissions properly?


  1. No ad-blocker. I tried accessing in both Chrome and Edge, but cannot open the campaign builder in either.
  2. It’s possible the folder permissions are not properly configured as I ran into permissions-related issues during installation, but I thought I resolved them since I was able to complete the installation. The mautic folder has read/write permissions for the non-root sudo user (xavier)

Looked a bit further into this and when I click the “Launch Campaign Builder” button the div with the campaign-builder class still has the hide class:


If I manually remove the hide class and add the builder-active class and interact with the campaign tree, it seems to work (not sure if that’s all that’s needed though).

Side note: Maybe it was a pointless attempt, but I tried to run mQuery('#campaign-builder').trigger('campaign-builder:show'); from the console but it didn’t do anything.

@xavier_h if it is a bug with the plataform, please open an issue on GitHub about this problem at GitHub - mautic/mautic: Mautic: Open Source Marketing Automation Software.

That way the community can fix it :slight_smile:

1 Like

@xavier_h it looks like your JS assets are out of date. Run this command php bin/console mautic:assets:generate, clear your browser cache and see if it helps.

Thank you both for the suggestions!

@patryk.gruszka I think your hunch might be right that I am missing something. Unfortunately, it doesn’t seem php bin/console mautic:assets:generate (although ran successfully) did not seem to have resolved the issue after clearing the browser cache

Updated to 5.0.3 and am no longer experiencing this!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.