Mautic Community Forums

All links changing to localhost

Hello all,



I am just doing some research to test Mautic features quickly. I have spinned an AWS instance, put Bitnami WAMP Stack (with Apache and PHP) on it and installed Mautic.



In the general settings I put the public IP as my Site URL (I do not have a registered domain at the moment)

https://www.screencast.com/t/fHedcdNo



However, when I create a form or email, all my post actions, tracking pixels have localhost in the URL instead of the public IP

https://www.screencast.com/t/bBvKhSqP

https://www.screencast.com/t/gjRdYHSl



Can you please help?



Many thanks

Hello all,

I am just doing some research to test Mautic features quickly. I have spinned an AWS instance, put Bitnami WAMP Stack (with Apache and PHP) on it and installed Mautic.

In the general settings I put the public IP as my Site URL (I do not have a registered domain at the moment)
https://www.screencast.com/t/fHedcdNo

However, when I create a form or email, all my post actions, tracking pixels have localhost in the URL instead of the public IP
https://www.screencast.com/t/bBvKhSqP
https://www.screencast.com/t/gjRdYHSl

Can you please help?

Many thanks

@evrentekin you have to put the correct directory path on log directory and cache directory you still have the WAMP path.

After doing this saved and clean cache folder (delete) the folder is located under app/cache

Thanks for the reply @ninjoan

I have updated my log directory and cache directory as:
%kernel.root_dir%/logs
%kernel.root_dir%/cache

and deleted everything under app/cache however I am still having the same problem.

mmmm… check your local.php file and look if the change has been saved

Yes it is there

https://www.screencast.com/t/mBG5t3vapwuT

edit the site_url a http://35.176.244.74/Mautic_2.10.1

Sadly still no luck

after that clean the cache