Mautic Community Forums

Amazon SES settings & where to set bounces

Hello,



So glad I found Mautic. Thank you very much to those who make it nice and easy. For the moment, it’s not working for me though. Long message, sorry, but I can’t go any further by myself. Any help/explanation is welcome !



:-)



Olga


  1. Amazon SES SMTP settings

    So, my Amazon SES SMTP settings won’t say ‘Success !’ I think the settings are good though because I can send emails from Mac Mail with them. It’s only in Mautic when I hit ‘test connexion’ that the wheel turns and turns, never stops.



    When I fill out a campaign form on my website (I log out of Mautic first and use a different location thanks to a VPN), here is the result :
  • in Mautic the contact goes to the pending segment
  • it says the first email has been sent
  • I don’t receive the email
  • the CRON results say:



    /usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:campaigns:trigger --force

    Triggering events for campaign 2

    Triggering first level events

    2 total events(s) to be processed in batches of 100

    0/2 [>---------------------------] 0%

    1/2 [==============>-------------] 50%

    [Swift_RfcComplianceException]

    Address set in PathHeader does not comply with addr-spec of RFC 2822.

    mautic:campaigns:trigger [-i|–campaign-id [CAMPAIGN-ID]] [-l|–batch-limit [BATCH-LIMIT]] [-m|–max-events [MAX-EVENTS]] [-f|–force] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [-n|–no-interaction] [-s|–shell] [-e|–env ENV]



    /usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:campaigns:rebuild --env=prod

    Rebuilding contacts for campaign 2

    0 total contact(s) to be added in batches of 300

    0 total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for campaign 3

    0 total contact(s) to be added in batches of 300

    0 total contact(s) to be removed in batches of 300

    0 contact(s) affected



    /usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:segments:update --env=prod

    Rebuilding contacts for segment 2

    0 total contact(s) to be added in batches of 300

    0 total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for segment 8

    0 total contact(s) to be added in batches of 300

    total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for segment 6

    0 total contact(s) to be added in batches of 300

    total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for segment 9

    0 total contact(s) to be added in batches of 300

    total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for segment 7

    0 total contact(s) to be added in batches of 300

    total contact(s) to be removed in batches of 300

    0 contact(s) affected



    Rebuilding contacts for segment 3

    0 total contact(s) to be added in batches of 300

    0 total contact(s) to be removed in batches of 300

    0 contact(s) affected



    /usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:email:fetch --env=prod

    0 emails processed for {xxx.com:993/imap/ssl}INBOX.bounces_telegram@mywebsite.com

    0 emails processed for {xxx.com:993/imap/ssl}INBOX.complaints_telegram@mywebsite.com


  • the logs (in app/logs) say:

    [2016-08-10 16:00:02] mautic.NOTICE: Swift_RfcComplianceException: Address set in PathHeader does not comply with addr-spec of RFC 2822. (uncaught exception) at /home/xxx/public_html/xxx/telegram/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Mime/Headers/PathHeader.php line 138 while running console command mautic:campaigns:trigger [] []





    Here are my email settings in Mautic (again, the same that work with Mac Mail) :

    Other SMTP settings / Amazon SES (I tried both)

    email-smtp.eu-west-1.amazonaws.com

    Port 587

    TLS with login



    In Amazon SES, I’ve verified my website and my email address. Everything is set up for the Ireland region (email-smtp.eu-west-1.amazonaws.com).




  1. Where to set bounces and complaints

    Here is how I set it up :

    In cPanel, I set up two email accounts : bounces@mywebsite.com and complaints@mywebsite.com (in addition to the telegram@mywebsite.com where I received the verification email from Amazon SES).

    In Amazon SES, I also set up SNS notifications for bounces and complaints.

    And in Mac Mail, I set up two files: one bounces, one complaints.

    Something redundant here, no ?

Hello,

So glad I found Mautic. Thank you very much to those who make it nice and easy. For the moment, it’s not working for me though. Long message, sorry, but I can’t go any further by myself. Any help/explanation is welcome !

:slight_smile:

Olga

  1. Amazon SES SMTP settings
    So, my Amazon SES SMTP settings won’t say ‘Success !’ I think the settings are good though because I can send emails from Mac Mail with them. It’s only in Mautic when I hit ‘test connexion’ that the wheel turns and turns, never stops.

When I fill out a campaign form on my website (I log out of Mautic first and use a different location thanks to a VPN), here is the result :

  • in Mautic the contact goes to the pending segment
  • it says the first email has been sent
  • I don’t receive the email
  • the CRON results say:

/usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:campaigns:trigger --force
Triggering events for campaign 2
Triggering first level events
2 total events(s) to be processed in batches of 100
0/2 [>---------------------------] 0%
1/2 [==============>-------------] 50%
[Swift_RfcComplianceException]
Address set in PathHeader does not comply with addr-spec of RFC 2822.
mautic:campaigns:trigger [-i|–campaign-id [CAMPAIGN-ID]] [–scheduled-only] [–negative-only] [-l|–batch-limit [BATCH-LIMIT]] [-m|–max-events [MAX-EVENTS]] [-f|–force] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-s|–shell] [–process-isolation] [-e|–env ENV] [–no-debug] [–]

/usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:campaigns:rebuild --env=prod
Rebuilding contacts for campaign 2
0 total contact(s) to be added in batches of 300
0 total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for campaign 3
0 total contact(s) to be added in batches of 300
0 total contact(s) to be removed in batches of 300
0 contact(s) affected

/usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:segments:update --env=prod
Rebuilding contacts for segment 2
0 total contact(s) to be added in batches of 300
0 total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for segment 8
0 total contact(s) to be added in batches of 300
total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for segment 6
0 total contact(s) to be added in batches of 300
total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for segment 9
0 total contact(s) to be added in batches of 300
total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for segment 7
0 total contact(s) to be added in batches of 300
total contact(s) to be removed in batches of 300
0 contact(s) affected

Rebuilding contacts for segment 3
0 total contact(s) to be added in batches of 300
0 total contact(s) to be removed in batches of 300
0 contact(s) affected

/usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:email:fetch --env=prod
0 emails processed for {xxx.com:993/imap/ssl}INBOX.bounces_telegram@mywebsite.com
0 emails processed for {xxx.com:993/imap/ssl}INBOX.complaints_telegram@mywebsite.com

  • the logs (in app/logs) say:
    [2016-08-10 16:00:02] mautic.NOTICE: Swift_RfcComplianceException: Address set in PathHeader does not comply with addr-spec of RFC 2822. (uncaught exception) at /home/xxx/public_html/xxx/telegram/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Mime/Headers/PathHeader.php line 138 while running console command mautic:campaigns:trigger [] []

Here are my email settings in Mautic (again, the same that work with Mac Mail) :
Other SMTP settings / Amazon SES (I tried both)
email-smtp.eu-west-1.amazonaws.com
Port 587
TLS with login

In Amazon SES, I’ve verified my website and my email address. Everything is set up for the Ireland region (email-smtp.eu-west-1.amazonaws.com).

  1. Where to set bounces and complaints
    Here is how I set it up :
    In cPanel, I set up two email accounts : bounces@mywebsite.com and complaints@mywebsite.com (in addition to the telegram@mywebsite.com where I received the verification email from Amazon SES).
    In Amazon SES, I also set up SNS notifications for bounces and complaints.
    And in Mac Mail, I set up two files: one bounces, one complaints.
    Something redundant here, no ?

No, it’s on Siteground.

Thank you Mxyzp but I would prefer if someone could tell me why I’m getting this Swift_RfcComplianceException message. Is it explaining why my SMTP won’t register in Mautic ?

My problem is that it doesn’t authenticate, yes.

I guess I’ll go ask Amazon SES. Thank you anyway !

:slight_smile:

Olga

Olga - please double check, that you selected the correct region. It needs to match with the one you use in Amazon SES.

Strange im using Siteground without a problem.

Thank you for your answers. They’re telling me it should be working.

dirk_s - I checked one more time just for you ! It’s all set up for Ireland. Below my domain settings in SES :
Email Feedback Forwarding:enabled
DKIM Settings Generated:yes
Bounce Notifications SNS Topic:arn:aws:sns:eu-west-1:023270985500:xxx_bounces
DKIM Verification Status:verified
Complaint Notifications SNS Topic:arn:aws:sns:eu-west-1:023270985500:xxx_complaints
DKIM Signing:enabled
Delivery Notifications SNS Topic:none
MAIL FROM Domain:eu-west-1.amazonses.com

And my email address settings :
Email Feedback Forwarding:enabled
DKIM Settings Generated:yes
Bounce Notifications SNS Topic:arn:aws:sns:eu-west-1:023270985500:xxx_bounces
DKIM Verification Status:verified
Complaint Notifications SNS Topic:arn:aws:sns:eu-west-1:023270985500:xxx_complaints
DKIM Signing:enabled
Delivery Notifications SNS Topic:none
MAIL FROM Domain:eu-west-1.amazonses.com

ninjoan - OK, that’s nice to know. I’m gonna get there too then !

I am about to contact Amazon SES and I’ll tell you afterwards what they tell me. They tend to answer after a few days, so be patient with me. (I just hope it’s not gonna be some little thing I’ll feel stupid to tell you about, that’s all …)

One of the issues with SES is that you have to send from verified email addresses or they will not authenticate. Have you check that the email address you’re sending from is authenticated at SES?

Yes, I did Ioanatik.

I’ve given up Amazon SES now though because I don’t want to pay for their support before it even starts working. I switched to Zoho and am getting the same RFC 2822 problem.

I am currently trying different ways to write my cron jobs.

My last try was with /usr/local/php56/bin/php-cli /home/xxx/public_html/xxx/telegram/app/console mautic:campaigns:trigger > /dev/null

And the answer was :
0/2 [>---------------------------] 0%
1/2 [==============>-------------] 50%

[Swift_RfcComplianceException]
Address set in PathHeader does not comply with addr-spec of RFC 2822.

mautic:campaigns:trigger [-i|–campaign-id [CAMPAIGN-ID]] [–scheduled-only] [–negative-only] [-l|–batch-limit [BATCH-LIMIT]] [-m|–max-events [MAX-EVENTS]] [-f|–force] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-s|–shell] [–process-isolation] [-e|–env ENV] [–no-debug] [–]

Well, it’s eventually working with Zoho and --env=prod at the end of my cron jobs …

@Olga22 The error message "Address set in PathHeader does not comply with addr-spec of RFC 2822. " points to this part of the specification: https://tools.ietf.org/html/rfc2822#section-3.4.1

Could you please double check your email setup fields? Especially: “Custom return path (bounce) address”. Are thos valid email adresses?

Hi dirk_s,

Your link opens on example.com. I tried to find the section you’re refering to on tools.ietf.org but couldn’t find it.

In my last message, I said the problem was solved because I didn’t see any error any more in the cron jobs. I discovered afterwards though that the emails were sending BUT I was still not receiving them.

So, I eventually took a few hours to set up a new Mautic install from scratch and I re-entered all the emails, forms, campaigns, settings, etc.

Now, it’s working, really working and it feels so great ! I’m occupied at customizing the unsubscribe page now. I still don’t know why I was getting this error. I guess the problem was in the database but I wouldn’t know how, why, what. So, sorry for those who encounter the same obstacle : the only thing I could find was to re-install Mautic. But that’s a solution.

Thank you all for the help and support. And again, bravo to all who work at making Mautic evolve. Every time, the improvements are a good surprise.

@Olga22 There are bugs with SES integration in Mautic. Try to use "Other SMTP settings and put your SES settings there. It works for me.

Although @Olga22 has decided not to use Amazon SES for now, the information on this Mautic documentation page walks you through how to set up Bounce and Complaint notifications through a webhook with Mautic.

If we configure a dedicated email box to monitor bounces, as describe in this tutorial:
https://medium.com/@AndreiVoica/how-to-integrate-mautic-with-amazon-ses-7fe066e9131c
and configure an SNS notification for bounces to send an email to that box,

Do we also need to configure the webhook described above? It seems that we only need one or the other…

Thanks for much for Mautic!!!

Right - you should use monitored inbox or webhooks, but not both.