Mautic Community Forums

Deduplicate cron is taking too long, any way to speed up?

Your software
My Mautic version is: 4.0.1
My PHP version is: 7.4
My Database type and version is: MariaDB 10.5.13

Running on 20.04 Ubuntu DO 8GB 80GB 4vCPUs

Your problem
My problem is: Running deduplicate is taking a LOOONG time on 134k contacts

These errors are showing in the log: N/A

Steps I have tried to fix the problem: Tried installing the custom deduplicate plugin but theres an issue with 4.0.1

Is there a way to increase the deduplicate cron speed ? Increasing batch limit like with the segments updates ? Also is there any way to increase the speed of other cron jobs well?

Post your my.conf to determine your database server settings. It takes a good amount of tuning to get adequate performance from a database server.

What are your max settings in your php.ini as well?

Hey, I have defaults on in php and mariadb. But your post did prompt me to look into memory allocation so as a result I changed

innodb_buffer_pool_size to 80% of RAM
key_buffer_size to 20M

The longer it runs the slower it gets