Mautic Community Forums

Error Mautic with Sendgrid

Hi!



I’m setting the Mautic as Sendgrid, but I’m having this error when testing sending emails:

Code:
Connection could not be established with host smtp.sendgrid.net [ #0] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host smtp.sendgrid.net [ #0] (code: 0) ++ Starting Swift_SmtpTransport !! Connection could not be established with host smtp.sendgrid.net [ #0] (code: 0)


has anyone experienced this error? Know how to solve?

I follow this tutorial for setting: http://rodrigodemetrio.com/blog/como-integrar-o-mautic-ao-sendgrid/

Thanks for attention.

Hi!

I’m setting the Mautic as Sendgrid, but I’m having this error when testing sending emails:

Connection could not be established with host smtp.sendgrid.net [ #0] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host smtp.sendgrid.net [ #0] (code: 0) ++ Starting Swift_SmtpTransport !! Connection could not be established with host smtp.sendgrid.net [ #0] (code: 0)

has anyone experienced this error? Know how to solve?

I follow this tutorial for setting: http://rodrigodemetrio.com/blog/como-integrar-o-mautic-ao-sendgrid/

Thanks for attention.

Hi Vinicius,

I had some problem with the API too and I’ve chosen to configure SendGrid as an SMTP server with the following settings:

Obviously you have to change the username and the password but in my case it works and I hope for you too.

Hi,

I’m having the same issue with various mail settings. I personally think this is a version 2 issue as my connection to various mail services is atrocious. One minute it connects next time I get the same error messages. Unfortunately i cannot get into my configuration as Mautic stalls continiously but if you are connecting via SMTP 25, 2525 or 587 you need to send as Plain Text. Also make sure you router has port 25, 2525 or 587 open. If you are running Mautic on a local machine as I am them aslo ensure port mapping is set to your local machine for the ports.

@Vinicius Gabriel @eurogroup problem solved?

@eurogroup you are using version 2 and this works? In this case, I would have to change the port 465 by one of those that you specified?