Error on cron job

Your software
My Mautic version is: 2.16.0
My PHP version is: 7.2

Your problem
My problem is: Setting up Cron jobs for Segments, and I receive the error log message. Command is: php /home/mautic/app/console mautic:segments:update

These errors are showing in the log: php /home/mautic/app/console mautic:segments:update

Steps I have tried to fix the problem: None


It doesn’t look like you’ve included the actual error you’re getting in the log. What exactly is your problem with setting up the cron job for Segments?


Doh! Sorry about that.

PHP Parse error: syntax error, unexpected ‘$value’ (T_VARIABLE) in /home/mautic/vendor/aws/aws-sdk-php/src/functions.php on line 36

This type of problem typically occurs when you are running the incorrect PHP version.
I see that you have indicated in your original post that you are running PHP 7.2, however would you mind double checking that? If you can post the output of php -v or a screenshot of Mautic > Configuration > System Info page, it would help.

This is from a different repo (not Mautic), but somebody was encountering an error with the same file as you vendor/aws/aws-sdk-php/src/functions.php when they were running a PHP version that was too old.

The aws sdk for PHP is supposed to be compatible with PHP 5.5+ but I agree – I would double-check your PHP version since mautic requires at least 7.2 (I run 7.3.x without issue.)

Is your mautic installation using AWS or running on AWS? I wonder why that error would come from the segments:update cronjob.

This is set up in a Digital Ocean VPS.

php -v gives me PHP 7.2.24 (cli) (built: Nov 4 2019 10:23:08) ( NTS )

So as an update, I installed Mautic on a brand new Ubuntu (instead of CentOS) VPS. The chron jobs run just fine on this Ubuntu VPS, however it would be nice to know why it won’t run on the otherwise vanilla CentOS VPS…

Hi, what version of Ubuntu did you end up using? Also having issues with Centos7…