Mautic Community Forums

Focus Item Form Submit Same Origin Issue

Im using a focus item and I have mautic installed on a subdomain.

Im getting the following error when I submit the form…



“Refused to display ‘http://mautic.mydomain.com/mautic/form/submit?formId=2’ in a frame because it set ‘X-Frame-Options’ to ‘SAMEORIGIN’.”



Is there another way I can get the form to submit in the time being?

Im using a focus item and I have mautic installed on a subdomain.
Im getting the following error when I submit the form…

“Refused to display ‘http://mautic.mydomain.com/mautic/form/submit?formId=2’ in a frame because it set ‘X-Frame-Options’ to ‘SAMEORIGIN’.”

Is there another way I can get the form to submit in the time being?

i’ve got a similar issue

Not sure how to help, but it sounds like a CORS access control issue

I have the same issue. I changed the SAMEORIGIN to Allow the site URL in http.conf but this is not resolving the problem. Any suggestion would be great!

I’ve been trying to debug this all morning, it doesn’t seem to matter what CORS settings you apply in the config, it just doesn’t seem to work.

Any help on this would be great. I have been working on this issue for a couple hours now and can’t figure it out.

Make sure in your admin config settings you have CORS set to ‘Yes’ and that you have only one url defined, which may be your full domain name ‘https://www.yourdomain.com’.

@DerekBuntin I have the same issue, adding the domain name in there makes no difference to the forms, just the javascript tracking as far as I could tell.
It is still reported as SAMEORIGIN, no matter what I set in the CORS settings on the config page.

@tdlabs what’s your website url?

Hi Derek,

Figured it out.
The guys at bitnami set the header to sameorigin in the apache configuration.
I changed that and it worked now.

Awesome, glad it’s sorted :wink:

[quote=21146:@tdlabs]Hi Derek,

Figured it out.
The guys at bitnami set the header to sameorigin in the apache configuration.
I changed that and it worked now.[/quote]
Could you please share with us what was the Lines of code added into the Apache configuration filé?

@Alcides Sure thing,

It’s in

/opt/bitnami/apache2/conf/httpd.conf

Not sure what line it’s on, but just use find (ctrl+W in nano) to find “SAMEORIGIN”

The modified code block looks like:

<IfModule headers_module>
    <IfVersion >= 2.4.7 >
        Header always setifempty X-Frame-Options GOFORIT
    </IfVersion>
    <IfVersion < 2.4.7 >
        Header always merge X-Frame-Options GOFORIT
    </IfVersion>
    RequestHeader unset Proxy
</IfModule>

If you know how to restrict it to one website in there, it would be really cool to know.