Fresh Mautic 4.4.0 via SSH and Composer - problem with installation

Try adding
at the beginning of command and not all commands need to be run at every update …

One of the command that should be run after every update is clear cache so add php like this and see if that works for you,

php bin/console cache:clear

Still the same:

Do you perhaps know what the problem is?

It’s a permission problem. You will probably need to talk to your host provider about this one. You can just manually clear the cache folder yourself if your Mautic is not loading property after update.

Just go inside the cache folder and delete everything in it.

Can you type me the right path to cache folder?

I can see only this:

If it is correct do you mean deleting ip_data, prod and ?

yes …

Screen Shot 2022-07-12 at 11.05.01 AM

then …

Screen Shot 2022-07-12 at 11.05.15 AM

Can you please tell me if the cache was cleared? And what this red notice is meaning?

I don’t know what it mean.

I also ended up with this log info:

[2022-07-12 19:18:45] mautic.EMERGENCY: Failed to clear Mautic cache. {“adapter”:“FilesystemTagAwareAdapter”} {“hostname”:“”,“pid”:3720}
[2022-07-12 19:18:45] mautic.NOTICE: Exception: Failed to clear FilesystemTagAwareAdapter (uncaught exception) at /home/ line 46 while running console command cache:clear {“hostname”:“”,“pid”:3720}
[2022-07-12 19:18:45] mautic.WARNING: Command cache:clear exited with status code 1 {“hostname”:“”,“pid”:3720}

Is this saying you anything?

1 Like

Hello techbill,

I would like to ask you about update.
Today, 4.4.1 has shown recently, I run this command:

composer update

and my Mautic went to installer…as I would like to install a fresh copy. Previous data was completly ereased.
Do you have any hints how to run update via composer correctly?

Do you have a backup copy of this file app/config/local.php before the update? You need it to restore it

I managed to restore the whole Mautic installation and I have this file already. I made a backup of app/config/local.php.
Can you tell me how to run update to not to throw myself and my Mautic installation into installer process after running “composer update” via command line?

There is an issue with the composer update right now

Just run the composer update then after it finish updating, restore that one file local.php back into the /app/config/folder and clear cache.

Thank you! It helped:)

1 Like

Hello techbill!

I replicated the steps with your composer.json file to do a clean installation but I faced this problem:


Does it mean that the file composer.json that you prepared last time is out of date?

Here’s what is inside the composer.json file:

“name”: “mautic/recommended-project”,
“description”: “Project template for Mautic 4 projects with composer”,
“type”: “project”,
“license”: “GPL-2.0-or-later”,
“homepage”: “Mautic Releases - Mautic Community”,
“support”: {
“user-docs”: “Mautic Documentation | Mautic”,
“developer-docs”: “”,
“chat”: “Mautic Community On Slack
“funding”: [
“type”: “other”,
“url”: “
“type”: “other”,
“url”: “Sponsor @mautic on GitHub Sponsors · GitHub
“authors”: [
“name”: “”,
“role”: “”
“require”: {
“composer/installers”: “^1.11”,
“mautic/core-composer-scaffold”: “4.x-dev”,
“mautic/core-project-message”: “4.x-dev”,
“mautic/core-lib”: “^4.0”,
“mautic/grapes-js-builder-bundle”: “^4.0”,
“mautic/plugin-citrix”: “^4.0”,
“mautic/plugin-clearbit”: “^4.0”,
“mautic/plugin-cloudstorage”: “^4.0”,
“mautic/plugin-crm”: “^4.0”,
“mautic/plugin-emailmarketing”: “^4.0”,
“mautic/plugin-focus”: “^4.0”,
“mautic/plugin-fullcontact”: “^4.0”,
“mautic/plugin-gmail”: “^4.0”,
“mautic/plugin-outlook”: “^4.0”,
“mautic/plugin-social”: “^4.0”,
“mautic/plugin-tagmanager”: “^4.0”,
“mautic/plugin-zapier”: “^4.0”,
“mautic/theme-aurora”: “^4.0”,
“mautic/theme-blank”: “^4.0”,
“mautic/theme-brienz”: “^4.0”,
“mautic/theme-cards”: “^4.0”,
“mautic/theme-coffee”: “^4.0”,
“mautic/theme-confirmme”: “^4.0”,
“mautic/theme-fresh-center”: “^4.0”,
“mautic/theme-fresh-fixed”: “^4.0”,
“mautic/theme-fresh-left”: “^4.0”,
“mautic/theme-fresh-wide”: “^4.0”,
“mautic/theme-goldstar”: “^4.0”,
“mautic/theme-mauve”: “^4.0”,
“mautic/theme-nature”: “^4.0”,
“mautic/theme-neopolitan”: “^4.0”,
“mautic/theme-oxygen”: “^4.0”,
“mautic/theme-paprika”: “^4.0”,
“mautic/theme-skyline”: “^4.0”,
“mautic/theme-sparse”: “^4.0”,
“mautic/theme-sunday”: “^4.0”,
“mautic/theme-vibrant”: “^4.0”,
“mautic/theme-trulypersonal”: “^4.0”
“repositories”: [
“type”: “git”,
“url”: “GitHub - dennisameling/FOSOAuthServerBundle: A server side OAuth2 Bundle for Symfony
“conflict”: {
“mautic/mautic”: “",
“mautic/core”: "

“minimum-stability”: “dev”,
“prefer-stable”: true,
“config”: {
“sort-packages”: true,
“secure-http”: false,
“allow-plugins”: {
“composer/installers”: true,
“symfony/flex”: true,
“mautic/core-composer-scaffold”: true,
“mautic/core-project-message”: true
“autoload”: {
“psr-4”: {
“MauticPlugin\”: “/home/”
“extra”: {
“mautic-scaffold”: {
“locations”: {
“web-root”: “/home/”
“installer-paths”: {
“/home/”: [
“/home/{$name}”: [
“/home/{$name}”: [
“mautic-core-project-message”: {
“include-keys”: [
“post-create-project-cmd-message”: [
“<bg=blue;fg=white> </>”,
“<bg=blue;fg=white> Congratulations, you’ve installed the Mautic codebase </>”,
“<bg=blue;fg=white> from the mautic/recommended-project template! </>”,
“<bg=blue;fg=white> </>”,
“<bg=yellow;fg=black>Next steps</>:”,
" * Install Mautic",
" * Read the user guide",
" * Get support: Support",
" * Get involved with the Mautic community:“,
" * Remove the plugin that prints this message:“,
" composer remove mautic/core-project-message”

Can you please look at it and help me move on with my installation?

Kind regards,


Look like your real path have changed again … it sound like your host create a new instance each time you start fresh so you need to check your real path and see if it match what in composer.json

Go back a few post up to see how to check real path in terminal in here.

Thanks a lot. It helped!

I would like to ask you one thing.

Do you have the same that after installation of Mautic with “your” composer.json file such things happen:

  1. Mautic icon do not show in the browser tab.
  2. National flags are not shown in the contact location.
  3. When someone submits a form the submitt message is showing on the separate browser window instead of above the form?

Perhaps you faced the same before?


  1. Never had that happened to me … Check see if file favicon.ico exists in your Mautic root folder
  2. Not every location have a national flag, I am seeing only some location with flag not all.
  3. I am not sure what you mean. I think form depends on where you set to redirect after submission.

Ok. It’s strange because this had happened when I’ve installed the Mautic for the first time with your file.
Then I updated the instance with the inner mechnism, not with the composer and everything started to work fine. Flags were shown, icon was visible (it is there all the time!) and forms show messags in the correct way.
It looks like I have to wait for 4.4.2…

Do you have the composer.json file that would install the Mautic instance not with the current version but e.g. 4.4.0?
I could install 4.4.0 and than update to 4.4.1 to see the results.

I can confirm, composer does not work on Mautic 4.4.8:

1 Like