Having trouble setting email send sequence

Your software
My Mautic version is: v3.0.2
My PHP version is: Php7

I can’t get mautic to send emails with predetermined sequence with cron, seems like sometimes it works, and sometimes doesn’t I play with settings back and forth so much that I loose control of what is really going on!

This is what I’m trying to do.

  1. I have a list of 3 contacts
  2. I want to send the 3 emails at a sequence
    – First email at minute 1
    – Second email at minute 3
    – Third email at minute 7
  3. When I click send, I want to be able to see them come in the inbox, start the sending sequence as soon as I hit “send” button

These are my cron settings, and my email is set to send batches of 1 email as queue:

0,15,30,45 * * * * /usr/local/bin/php /home/vuxi5632/public_html/brunovincent.net/mautic/bin/console mautic:segments:update >/dev/null 2>&1

5,20,35,50 * * * * /usr/local/bin/php /home/vuxi5632/public_html/brunovincent.net/mautic/bin/console mautic:campaigns:update >/dev/null 2>&1

10,25,40,55 * * * * /usr/local/bin/php /home/vuxi5632/public_html/brunovincent.net/mautic/bin/console mautic:campaigns:trigger >/dev/null 2>&1

1,3,7,11,12,17,59 * * * * /usr/local/bin/php /home/vuxi5632/public_html/brunovincent.net/mautic/bin/console mautic:emails:send >/dev/null 2>&1

I think I answered this on Facebook :slight_smile:
You said this is a segment email and you are using the queue.
Can you plz let us know how you build the queue? In browser window? (Progress bar) or by timing (Publish at…)

Also: why not a campaign?

There is more here about crons and emails: Matching SES send rate

Hi Joey,

Is this better than facebook to ask questions? Not sure, I’m in Thailand and the west is sleeping…so I thought I would ask in both?

I’m sending emails by clicking on “emails” drop down and then send, it’s not a campaign, I haven’t tried that feature yet.

Okay, so what happens here is:
You are placing 3 emails in a queue. If you want to send just 1 of them with each cron, use this format:
mautic:emails:send --message-limit=1

GL to you!

Actually it’s kind of strange, it DOES work, but only in 2 cron settings:




And then I tried this:


and this: