Import speed issue

Your software
My Mautic version is: 4.4.9
My PHP version is: 8.0
My Database type and version is: marizdb 10.4

Your problem
My problem is: Import speed issue

These errors are showing in the log: nothing

Steps I have tried to fix the problem: I have optimized mysql, PHP also i have upgarded the server with dedicated 32GB RAM 8Cores and 2TB drive.

Hello experts,

Nice to meet you

I’m getting list import issues with my mautic application

anybody here who can assist me to fix the import issue?

let me give you brief about the issue once.

When I am importing a list in mautic then the list import process goes on but the contacts are getting imported very slow which should be fast, and there is no option in mautic from where we can regulate the speed, and i have also checked from server nothing is there which can creates the issue.

Hi, we need a bit more info.
What is the speed you have achieved?
Slow means: 1-2 / sec
Normal for me means: 30k imported in 8-12 min
With your resources and properly configured database you should achieve 100k/hour 20min.

Hello Joeyk,

No, i’m not getting this import speed as you mentioned if i get this import speed i’m will be setisfied No, i’m not getting this import speed as you mentioned if i get this import speed i’m will be satisfied, but currently the import spped in my mautic is 1 sec 1 email, and when i upload 15K list it taking 2.5 Hours to import completely.

Exactly i’m getting this
Slow means: 1-2 / sec

resources wise i’m using dedicated server with 32GB RAM, 8 Cores processor, and 2TB NVMe Drive.

Okay, I noticed it - happens if you have issues with indexes.
Can you check if you have the email column indexed in your leads table?

In mysql:


1 Like

Hey @joeyk

jumping in with my answer to your question, mine looks like this

| email                     | varchar(191)        | YES  | MUL | NULL    |

BUT if you have

| email | varchar(191) | YES | NULL | NULL |

In other words email is not indexed as multiple, your import speed will suffer.

1 Like

aha, okay good :smiley:

what would be the case that it is not indexed? or not MUL

Nono, yours is file. You have “MUL”, thats good.

NUL or empty is not indexed


I have checked you describe and i found this in my DB.

email varchar(191) YES NULL

Is it good or bad?, and if due to this the import speed is slow then how i can edit or update the index?

We don’t know if it’s bad, because the info is not visible.
You are pointing at the “default value” and we need the indexes.

Plz give this command in SQL and see what you get for email:


Actually I can see, that you don’t have an index.

Run this command:

CREATE INDEX idx_email ON leads (email) USING BTREE;

Check speed now

1 Like

Thank you! This solved my problem as well. I wonder why this field is not indexed by default?

I’m not sure. For me it’s standard procedure to add it. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.