Installed mautic 4.4.10 with softaculous - getting 403 error

Your software
My PHP version is :8.0
My MariaDB version is 10.6.15

Updating/Installing Errors
I am: Installing
installing via Softaculous on Rochen hosting (who host the joomla official website)

These errors are showing in the installer : it appeared to have installed properly, according to softaculous

These errors are showing in the Mautic log : the log files directory in mautic is empty.

Your problem
My problem is :
I installed mautic using softaculous on a wp site, in the recommended subdirectory of mautic. When I click on the link to go to the login page - - I get 403 forbidden error.

Steps I have tried to fix the problem : If I rename the .htaccess file in the mautic directory I then get after a slight delay, “there has been a critical error on this website. Learn more about troubleshooting wordpress”. Which is not what I expected as I thought I would get some mautic error.

I’ve looked at the file and folder permissions, and all the folders are 755 and the files have 644 permissions, in the mautic directory at least. The mautic directory has folder permission of 755.

Any suggestions gratefully received. I know it is shared hosting, but I have set the execution time max to 240 seconds, and I’ve not had problems with Rochen previously.

Hey there, you might like to take a look at this Github issue:

It’s preferred to use Mautic in a subdomain rather than a sub folder, but there are some workarounds mentioned.

You may need to ask Rochen for some help on their specific setup if you’re struggling to get this working.

Ok, thanks for that. Having read about it as you suggested, I’ve decided that rather than mess with the .htaccess file I’ve decided to uninstall and create a subdomain as that will be the better-supported way going forward.

Oh. I’ve created my subdomain - - and installed mautic 4.4.10 using softaculous in the root of it (ie, no mautic subdirectory), but still get the ‘403 forbidden’ message :confounded:

I gather the subdomain might take a while to propagate round the internet - I tried to log in to mautic only about 20 minutes after creating the subdomain. Could that be the reason?


Softaculous has some rules in place that prevent accessing some files and executing some of the functions in order to be able to use mautic with it, you have to adjust the rules.

I think I can adjust that for you if you are interested, drop me a PM.

Regards, M.

403 is a forbidden access.

Things to check, in that order:

  1. create a file only containing the words “hello world” at the root of your www and try accessing it directly (and you should read “Hello world”).
  • If it fails, it could be directory permissions and/or server configuration.
  • if it succeed, it is probably a server configuration (read htaccess misconfiguration) - but not a permission issue.
  1. check htaccess for any “deny from” and comment all of it and test…

** I suspect that those lines in your htaccess are breaking it:

** EDIT **
Make sure to leave the composer bit active (don’t comment it - actually those files shouldn’t even be there to start with)

Yes, its forbidden and softaculous might trigger 403 if the rules are too strict

You will find that upgrading Mautic also breaks the .htaccess file. My hosting company is kind & efficient at fixing that. Perhaps it’s only an issue for those of us installing both WordPress & Mautic via Softaculous–I don’t know. Do be aware that Mautic is headed down a path (Composer dependence) that will eventually kick Mautic off of shared hosing entirely. Because, Composer has administrative power that can’t be safely trusted on shared hosting. That’s unfortunate, because for the vast majority of us, shared hosting is completely sufficient with a small mailing list.

I’ve been trying to get a fully-managed container service such as to offer Mautic hosting, but there is not enough demand yet. That may change if/when Mautic becomes uninstallable on shared hosting.