Mautic Community Forums

Landing page editor rewrites code

Hello everyone!



I’ve been trying create a landing page that mimics an existing page on my client’s site used for setting appointments. Many of our recent email campaigns have included a link to set their next appointment, so I wanted to create a landing page so I could exact more information on whether they’re converting from the emails or finding the page via organic means or visits. However, when I try to use the landing page custom html tool, it butchers my code (various scripts stop working, certain spans disappear). Has anyone else had this problem? Is there a solution? (I did visit https://github.com/mautic/mautic/commit/c78cbd628a4d0398c339ee5c087cfe4928799369) and make those changes hoping that it would solve the problem, but I don’t notice a difference.



Is there a better solution than trying to force Mautic to allow my code? Would it make sense to create a blank landing page and have it redirect to the ~real~ version of the page, or would this invalidate any attempts at tracking?



Thanks,



Conor M

Hello everyone!

I’ve been trying create a landing page that mimics an existing page on my client’s site used for setting appointments. Many of our recent email campaigns have included a link to set their next appointment, so I wanted to create a landing page so I could exact more information on whether they’re converting from the emails or finding the page via organic means or visits. However, when I try to use the landing page custom html tool, it butchers my code (various scripts stop working, certain spans disappear). Has anyone else had this problem? Is there a solution? (I did visit https://github.com/mautic/mautic/commit/c78cbd628a4d0398c339ee5c087cfe4928799369) and make those changes hoping that it would solve the problem, but I don’t notice a difference.

Is there a better solution than trying to force Mautic to allow my code? Would it make sense to create a blank landing page and have it redirect to the ~real~ version of the page, or would this invalidate any attempts at tracking?

Thanks,

Conor M