Mail DSN don't let me connect to my email server

Your software
My Mautic version is: 5.0.3
My PHP version is: 8.0
My Database type and version is: MySQL 8

Your problem
My problem is: Can’t make email dsn work. I was working perfectly with Mautic 4 but now in Mautic 5 with the change of mail transport I can’t get authenticated

These errors are showing in the log: (no error there, only in the config screen)
Using currently saved DSN: smtp://

Failed to authenticate on SMTP server with username “” using the following authenticators: “LOGIN”, “PLAIN”. Authenticator “LOGIN” returned “Expected response code “235” but got code “535”, with message “535 Incorrect authentication data”.”. Authenticator “PLAIN” returned “Expected response code “235” but got code “535”, with message “535 Incorrect authentication data”.”.

Steps I have tried to fix the problem:
I am using the same credentials than in mautic 4, but as I see I need maybe synfony mail transport.
Since I installed Mautic 5 via Softaculous and not manually probably that is not installed.

What I need to know if I need to install something else in the server or in mautic directory or if the error is some kind of bug or if I am configuring this wrong.




In the config file it appers like this:

‘mailer_dsn’ => ‘smtp://’,

It creates double “%” and it shouldn’t but if I remove the double % then it just won’t recognize the server or the user email account.

What I found is that the “lock” icon is there and in this part: %%F0%%9F%%94%%92
This means: :lock:

Yes, that icon.
I am not sure that is an expected behaviour and it seems that this is breaking the password recognizing.
So… I tried to remove that “lock” and it just now won’t recognize the server or with another tweaking, the account.

This is probably a bug. Should I report it as that?

Updated symphony mailer to 5.4

[donitalo@cat marketautomation]$ composer show | grep symfony/mailer
symfony/mailer v5.4.36 Helps sending emails
[donitalo@cat marketautomation]$

But still have the same issue.

So probably is not the mailer but, or I am configuring something wrong or there is an issue in the softaculous installed version or something else I can’t locate.

I’m experiencing the same problem even after attempting to update the SMTP settings. My intention was to switch to a different sender, but now I’m unable to establish a connection between the DSN and any of my SMTP accounts. This includes the original one that was previously functioning properly. Did you ever find the fix?

I had the same Issue with Mautic 5. Found out that in the password the special char ‘<’ was not properly saved. I removed it. Then it worked.

Thanks to answer.
To understand better, you changed your password removing special characters or changed the way is saved in the config file?

I just removed the special char.

Edited answer [ was to ambigious ]:
I just removed the special char from the password. I saved the password from the backend, not in the config file.

Thanks will test it today

Perfect solution, thanks!

Well mcphil gave the solution

Is the next comment to yours.

In summary, there is an issue using some special characters, so tested it with less “strange” characters, in my case tried with “_” or “-” instead of “^”, “~” or non universally used ones and it works.

Why this happens? Maybe this symphony version is using a different character table? who knows, but the solution works and now I can use Mautic 5.

Another question, I am having problems with the IMAP

Error communicating with the IMAP server: [CLOSED] IMAP connection broken (server response)

Same password. Works great on SMTP but in imap… nope.

You faced the same issue?

el problemas no es con las contraseñas con caracteres extraños, revisen en el campo donde se coloca la contraseña existe un icono de un candado color amarillo, borren ese icono luego coloquen la contraseña que deseen

1 Like

Haven’t tried yet. Trouble really started with an error 500 after entering the Imap/Bounce-Details. I erased everything related in the conf file, than retried with smtp first (then came the issue with the special char) and then I stopped working on this project for this week. Advice: Check the array in the conf file if there is anything missing for proper imap. Would be happy to know if you could solve this one.

Are you using Amazon SES?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.