Mautic Email Queue processing,why do Email Sending Time is obviously different from arriving time of receivers Inbox

It seems a good solution. the sent time has interval 2 minutes to send. I still test if this can solve my problem.

I test by Channels–Emails(you called it Broadcast)
The time issue is still there. and The delay time is longer.

The other email show a little shorter.

Could you plz share the broadcast cron?

Sorry. I thought I have posted it.
0 0,12 * * * certbot renew --no-self-upgrade >/dev/null 2>&1
*/5 * * * * /usr/bin/php /var/www/html/bin/console mautic:segments:update >/dev/null 2>&1 #mautic-segments-cron
*/3 * * * * /usr/bin/php /var/www/html/bin/console mautic:campaigns:rebuild >/dev/null 2>&1 #mautic-campaings-rebuild-cron
*/3 * * * * /usr/bin/php /var/www/html/bin/console mautic:campaigns:trigger >/dev/null 2>&1 #mautic-campaigns-trigger-cron
*/4 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null 2>&1 #mautic-email-send-cron
*/2 * * * * /usr/bin/php /var/www/html/bin/console mautic:broadcasts:send --limit=2 >/dev/null 2>&1 #broadcast send
*/15 * * * * /usr/bin/php /var/www/html/bin/console mautic:webhooks:process >/dev/null 2>&1 #mautic-webhooks-cron
0 0,12 * * * /usr/bin/php /var/www/html/bin/console mautic:reports:scheduler >/dev/null 2>&1 # generating reports
*/1 * * * * /usr/bin/php /var/www/html/bin/console mautic:email:fetch >/dev/null 2>&1 #fetching email from inbox
*/2 * * * * /usr/bin/php /var/www/html/bin/console mautic:import >/dev/null 2>&1

I think --limite=2 The number 2 refers to 2 minutes, not 2 emails, right? because the email sending comes with 2 minutes intervals.

– limit = 2 means 2 emails. You set your cron to be launched every 2 min.
But the settings are still not okay, you are generating emails every 2 min, but sending every 4 min. After 12 minutes you will be sending out 6 minutes old emails.

Change to this:
*/2 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null

If this one */2 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null,
two email situation below
Email1: Sending 3.46 Arrived Time:3:48 (Delivered after 124 seconds)
Email2:Sending 3:42 Arrived Time:3:44 (Delivered after 128 Seconds)

If this one */3 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null,
two email situation below
Email1: Sending 4:09 Arrived Time:4:08 (Delivered after 68 seconds)
Email2:Sending 4:06 Arrived Time:4:04 (Delivered after 139 Seconds).

It is better than before not above 300 seconds. Great. Thank you.
Do you have ways to make it within 60 seconds?

I also am testing the campaign. let you know

I think the campaign trigger time needs to adjust well? currently this email:sending crob below
this one */3 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null,

All created time for the emails of the campaign is the same at 17:00

As I suggested use the broadcast, not the campaign.
Are you using now broadcast or campaign?
Maybe watch my video again? :slight_smile:

Also, I have seen your video. Maybe I cannot see how to solve my issue.
The broadcast is good for bulk sending at one time. I also will use the automation drip campaign with sequential emails. This feature is also important. I have tested the change cron for the campaign trigger below but the campaign doesn’t trigger
*/3 * * * * /usr/bin/php /var/www/html/bin/console mautic:campaigns:trigger --limit=2 >/dev/null 2>&1 #mautic-campaigns-trigger-cron

I can’t help you further, as I don’t understand 100% what you are trying to achieve and why are you sending so slow. Maybe Mautic cannot fulfill your needs on this one.

Thank you Joey! I have studied Mautic for three months and try to understand how it works, I will explore deep to find ways.

Hi Joeyk
Finally, I have solved the problem for the issue of email created time

For the Broadcast, if you only send N emails, we can set only cron below.
*/2 * * * * /usr/bin/php /var/www/html/bin/console mautic:broadcasts:send --limit=N >/dev/null 2>&1 #broadcast send
And not need to set below
*/4 * * * * /usr/bin/php /var/www/html/bin/console mautic:emails:send --message-limit=2 >/dev/null 2>&1 #mautic-email-send-cron

Otherwise, they will conflict with each other.

Re the Campaign. we can set below
*/3 * * * * /usr/bin/php /var/www/html/bin/console mautic:campaigns:trigger --campaign-limit=N >/dev/null 2>&1 #mautic-campaigns-trigger-cron.

Now everything works well without setting the queue.
Check this infor:Mautic Command Options and Arguments

Thanks for the feedback. Yeah getting rid of the queue makes it more simple.