Mautic Community Forums

Mautic OAuth 2 Error

We’re having trouble getting OAuth 2 to work.



We’ve set up the configuration in Mautic to use OAuth 2 and generated the client secret and tokens.



We’ve set up Apache to use SSL with a self signed certificate.



When we visit https://subsomain.mydomain.com/mautic, We get the usual security exception error, and after accepting the errors, we are able to use Mautic normally.



While trying to redirect the user for OAuth token, I am able to redirect the user to http://subdomain.mydomain.com/mautic/oauth/v2/authorize?

This causes the login prompt to appear.



However, it fails to redirect after the user enters the credentials with a 404 Not Found error. This error is displayed by Mauticbot and not Apache.



The same error appears if I send the user to the above authorization URL with https instead of http.



My guess is, its probably some error in Apache configuration, but not sure what it might be. Any help is appreciated.

We’re having trouble getting OAuth 2 to work.

We’ve set up the configuration in Mautic to use OAuth 2 and generated the client secret and tokens.

We’ve set up Apache to use SSL with a self signed certificate.

When we visit https://subsomain.mydomain.com/mautic, We get the usual security exception error, and after accepting the errors, we are able to use Mautic normally.

While trying to redirect the user for OAuth token, I am able to redirect the user to http://subdomain.mydomain.com/mautic/oauth/v2/authorize?
This causes the login prompt to appear.

However, it fails to redirect after the user enters the credentials with a 404 Not Found error. This error is displayed by Mauticbot and not Apache.

The same error appears if I send the user to the above authorization URL with https instead of http.

My guess is, its probably some error in Apache configuration, but not sure what it might be. Any help is appreciated.

I have same type of problem. I have to use the Oauth 2 that is required on the site i’m trying to place the Mautic api key on.
i’m adding screen shots to show step1, 2 and 3

same here, any solution? I’ve installed API /lib folder into site’s root as per instructions still getting 403 error

Day 3 of banging my head of a wall trying to figure out how to get the API to work, I’ve configured it and installed package yet I get HTTP 403 error when trying to connect to zapier plugin, but it works at mautic.net test site I setup, just not on self hosted, what am I doing wrong?

I noticed this too. Zapier worked on my hosted account but not on my self-hosted instance. It gives me the following error when I set it up (using the current callback URL).

[quote]Oh, foo.

Zapier could not connect to your account.

Could not verify SSL certificate. Please check certificate installation for domain![/quote]

The same here also, any solution yet?
Plz its important for me!

One issue I can see with @vcdesigns screenshots is that there’s a double slash in the URL on the third screenshot, e.g. …//oath/v2/authorize… That’s what caused the 404 error.

Are any of you able to provide screenshots similar to what are displayed earlier? The more information that’s provided, the easier it is to troubleshoot. I have OATH1 and OAUTH2 API connections configured successfully in my self-hosted instance of Mautic and will offer as much help as I can.

unfortunately, the problem stays the same

What’s wrong with this link

http://email.infusionsoftronic.com/oauth/v2/authorize?action=create&authenticity_token=fgs0naTKIgcx%2FINpAfEu3oZCMfaZMIzebIzeXrhuoY5J5%2FYGdf4%2FAZVKLQrJ3XWvYhXnjSc3lGx1rUkQQhOL7Q%3D%3D&controller=autoresponders&id=a44762d8-c83b-4abf-a298-80777f6c603a&identity_id=99da5704-7fc1-4a03-86b8-0705342bae9f&request=%23<ActionDispatch%3A%3ARequest%3A0x00557778b42658>&settings[client_id]=7_3pzax7s8qlc0soo4ockocwg44c8swgo0gcco840s08kkw4g8g8&settings[client_secret]=1q7l1wye8hgkwgscwwwow08wosgowsg440g08scgw44c0kg8s4&settings[domain_name]=http%3A%2F%2Femail.infusionsoftronic.com&settings[redirect_uri]=%2Fmautic&type=mautic&utf8=✓

http://i4campaigns.com/images/step3.jpg