Prevent mautic from being indexed by Google

Your software
My Mautic version is: v4.4.8

Your problem
My problem is:

my mautic login url is appearing in Google search results. Is there a way to prevent this via mautic’s settings?

Or is currently the only solution to manually edit the login page template, adding <meta name="robots" content="noindex">


The best solution to that is to advertise it at the vhost level where your server will let know Google to stay away.

(it doesn’t really make sense to tell a robot to visit a page to then tell him to forget about it and get lost)

To do so, add the following in your vhost configuration:

Header set X-Robots-Tag "noindex"
1 Like

I’m sure somewhere in the settings inside of Mautic it’s switchable. Don’t know at the moment where.
But you use a very old version of Mautic. in my 4.4.10 that worked. Maybe 5.0.4 also.
Hadn’t checked. But my Mautic is not find by search engine.

1 Like