Running integration from command not working after upgrade

Your software
My Mautic version is: 3.3
My PHP version is: 7.4
My Database type and version is: mysql

Your problem
My problem is: Icommands that run an integration not working after upgrading to v3

These errors are showing in the log:

        $container = $this->getContainer();
        $integrationHelper = $container->get('mautic.helper.integration');
        $integrationObject = $integrationHelper->getIntegrationObject('THCampaignExport');

IntergrationObject is returning false.

Steps I have tried to fix the problem:
I added the integration into the config referencing the correct class ensures that the name ends with Integration. When I run the command locally I get the error ‘call to member function campaignExports() on bool’. I debugged with xdebug and noticed that inside the IntergrationHelper class on line 114 when the code gets the list of plugins, the integration is not listed within the services of the bundle. I have also tried updating the version number and clearing the cache. Another worrying note to add is after updating the version number the system is expecting me to reference all 16 dependency injections in the config for the AbstractIntegration class. The console command which is ran daily was working prior to the upgrade.

Use dependency injection. Some stuff are not accessible via container since dependency injection is the preferred way.

I do not think this is so much Mautic thing as it is Symfony