Some Upgrade Woes this morning

Your software
My PHP version is : 7.3.18
My MariaDB version is 10.3.22-MariaD

Updating/Installing Woes

Hi all, I performed the upgrade this morning. I had issues with the web gui approach and had to use the cli to complete.

  1. Upgrade to 2.16.3 beta went well.
  2. Cleared cache and clicked upgrade to V3 on the notification
  3. GUI updated to downloading/extracting
  4. Went to moving files stage(3) and then appeared to get stuck. No movement for over 20 mins
  5. SSH’d in, and noticed no apparent movement in files, no entries in logs etc.
  6. Waited a bit longer.
  7. Tried the app/console mautic:update:find. Received permission denied. Noticed that the console file was now read only. chmod again. Received message how to update.
  8. Ran PHP Script as prompted. Done very quickly.
  9. GUI checks indicate on v3.

Couple of small things found so far, the gray silhouette avatar by my profile name appears missing, and if I go into my profile account, make a small change (timezone), when I apply I receive an “email already in use message”.

I shall carry on testing.

Thanks all. Richard

Just tried the upgrade on my second box. (All data was backed up). I had exactly the same issue on upgrade. The 2.16.3 to 3.0.0 got stuck on the Web GUI upgrade process at the relocating files stage. I took over with the stage 7 chmod stuff.

The common denominator is I use nginx on these boxes. Configuration is done under Laravel Forge.

The gravatar in the navbar is still missing however my users/profile does update so something on my first box affecting that. Time to poke around :slight_smile:

I’m wondering if I how I setup 2.16.2 originally may have been a factor in this. I did both setup from cloning the git repo, then allowing composer to install the parts needed. I ended up wiping one of the installs (1st one) this morning and re-installing from scratch with the downloadable zip file and so far that seems to be fine.

Thanks for your detailed analysis. Upgrading from the GitHub version (by cloning) is not supported, great to hear that it works when you use the downloadable zip file.

FYI based on your feedback I just added a pre-upgrade warning for users who installed Mautic by cloning from GitHub:

Regarding Gravatar, I’m also seeing a broken avatar if I run Mautic 3 on my local instance (which is not publicly accessible). If I run Mautic 3 on a publicly available instance (e.g., I’m seeing the default avatar as expected. Are you seeing the same? It might be a code bug, will need to check. This also seems to apply to Mautic 2 as far as I could test. Curious to hear what your experience is with this.

If you come across any other issues, please do let us know!

No, these were on publicly available instances. I don’t have a local iinstall. That said, I saw this issue on both the github install --> one-click upgrade. A fresh install from the zip of 3.0.0 gives me the full gravatar fine. Thanks.

Just confirming the gravatar issue on local instance for both version 2 and 3.