Mautic Community Forums

Swift transport error

Your software
My Mautic version is:3.0
My PHP version is:7.3

Your problem
My problem is:
In LoggerPlugin.php line 124:

Cannot send message without a sender address
Log data:
++ Starting Swift_Transport_EsmtpTransport
<< 220 myHost.com ESMTP Postfix

EHLO hub.mydomain.com

<< 250-myhost.com
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250-SMTPUTF8
250 CHUNKING

STARTTLS

<< 220 2.0.0 Ready to start TLS

EHLO hub.mydomain.com

<< 250-myHost.com
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5 PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250-SMTPUTF8
250 CHUNKING

AUTH LOGIN

<< 334 VXNlcm5hbWU6

aW5mb0B0ZWNocGhlbm9tZW5vbi5jb20=

<< 334 UGFzc3dvcmQ6

RGlhYmxvdGVrMTk3OA==

<< 235 2.7.0 Authentication successful

++ Swift_Transport_EsmtpTransport started
!! Cannot send message without a sender address (code: 0)

swiftmailer:spool:send [–message-limit MESSAGE-LIMIT] [–time-limit TIME-LIMIT] [–recover-timeout RECOVER-TIMEOUT] [–mailer MAILER] [–transport TRANSPORT] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-e|–env ENV] [–no-debug] [–]

These errors are showing in the log: listed above

Steps I have tried to fix the problem: cleared cache restarted postfix & dovecot and threw a silver dollar down a wishing well

A post was merged into an existing topic: SwiftMailer Error: Cannot Send Message Without Sender Address