Task & Opportunities Plugin

Here is a task and Opportunities plugin. https://github.com/redmantech/Mautic_CRM

Here is a task and Opportunities plugin. https://github.com/redmantech/Mautic_CRM

Do you have any detail on what this is supposed to do? it seems very interesting.

@mroberto Really great plugin. Thank you for sharing with community

No worries Kuzmany2.

Hey, thanks for sharing! Great addition. I have issues to install it. I move it to the plugins folder and clear the cash, add the job to cron to update and nothing happens. Then when i try to install it in Install plug in and it does not show any new changes.

I noticed that there is another build in folder - MauticCrmBundle, should i remove it prior to that, or merge them?


Hello Miracle,

MauticCrmBundle is part of the mautic installation this is not my plugin.

First move the Mautic_CRM to the plugin folder when you are done clear cache
rm -rf app/cache/*

then you need to run
php app/console doctrine:schema:update --force

@mroberto Any plans to contribute this back to the core code base? So that it is part of Mautic by default?

@Miracle maker Just had some problems as well. Make sure that it is a folder named CustomCrmBundle under plugins, any other name won’t work

I have tried it but cant install yet

Anyone having issues with a memory leak or just using a decent amount of memory when accessing the “Manage Opportunities” or “Manage Tasks” pages?

I installed it and followed up with php command. Unfortunately, I see 500 error when I want to view the CRM of contact details.

I had to uninstall it.

Please update it for 2.1.1

Thank you.

It works now.

Suggestion: Task board like. https://taskboard.matthewross.me/

New Update on Plugin, feedback welcome create issues on github.


I am using this plugin on mautic 2.16.3, appears to be working fine except it is throwing errors in the log when attempting to view the task list as well as when viewing a contact with a completed/uncomplete task.

Unable to toggle the task list which we need working.

Would appreciate if someone could point me in the right direction as to which files would need fixing to make it work properly again.

Kind Regards