Mautic Community Forums

Unable to connect with TLS encryption

I’m having an issue getting E-mails working, because I don’t feel like retyping everything though, checkout my Stack question for greater detail



http://stackoverflow.com/questions/37280019/mautic-unable-to-connect-with-tls-smtp



tl;dr;



I’m using SMTP with TLS to send emails through Mailgun. I have doubly, triply verified that my credentials are correct. And if I set encryption to “none” it works. But with “TLS” I get an error.



But, if I copy the code from /app/bundles/EmailBundle/Controller/AjaxController.php::testEmailServerConnectionAction() into a test file, I’m able to connect and send emails using TLS. So I’m not sure why I’m getting the error.



Any help is appreciated, reply here or on the stack question. Thanks

I’m having an issue getting E-mails working, because I don’t feel like retyping everything though, checkout my Stack question for greater detail

http://stackoverflow.com/questions/37280019/mautic-unable-to-connect-with-tls-smtp

tl;dr;

I’m using SMTP with TLS to send emails through Mailgun. I have doubly, triply verified that my credentials are correct. And if I set encryption to “none” it works. But with “TLS” I get an error.

But, if I copy the code from /app/bundles/EmailBundle/Controller/AjaxController.php::testEmailServerConnectionAction() into a test file, I’m able to connect and send emails using TLS. So I’m not sure why I’m getting the error.

Any help is appreciated, reply here or on the stack question. Thanks

Yeah, we ended up finding this is an issue with TLS, SwiftMailer, and PHP 5.6. Downgrading to PHP 5.5 resolved the issue.

Just out of curiosity, what version of PHP were you running when you tested that?

I have updated the Stackoverflow quesiton with my findings if you’re interested in more details.

I was experiencing the same issue and this was resolved by disabling SMTP Restrictions in my server environment as per the attached image.

I was able to use “Amazon SES” as my option in “Service to send Email through”.