Mautic Community Forums

Uncaught TypeError: #<Object> is not a function

Hi



I use Joomla and get the following error in the browser console:

Code:
Uncaught TypeError: # is not a function at Array.forEach (native) at Function.forEach (https://www.xxxxxx.com/media/system/js/mootools-core.js:5:460) at Array.each (https://www.xxxxxx.com/media/system/js/mootools-core.js:9:303) at HTMLDocument. (https://crm.xxxxxx.com/mtc.js:14:145) at Object.MauticJS.dispatchEvent (https://crm.xxxxxx.com/mtc.js:10:168) at https://crm.xxxxxx.com/mtc.js:70:90 at XMLHttpRequest.xhr.onreadystatechange (https://crm.xxxxxx.com/mtc.js:7:150)

Any idea what is wrong?

Hi

I use Joomla and get the following error in the browser console:

Uncaught TypeError: #<Object> is not a function
    at Array.forEach (native)
    at Function.forEach (https://www.xxxxxx.com/media/system/js/mootools-core.js:5:460)
    at Array.each (https://www.xxxxxx.com/media/system/js/mootools-core.js:9:303)
    at HTMLDocument.<anonymous> (https://crm.xxxxxx.com/mtc.js:14:145)
    at Object.MauticJS.dispatchEvent (https://crm.xxxxxx.com/mtc.js:10:168)
    at https://crm.xxxxxx.com/mtc.js:70:90
    at XMLHttpRequest.xhr.onreadystatechange (https://crm.xxxxxx.com/mtc.js:7:150)

Any idea what is wrong?

Hi, same error with Joomla 3.6.5 and Mautic 2.7.

It’s seem that Mootools is not compatible with Mautic now…
I don’t know how to fix it …

Nobody having any idea how to fix it?

Hi.

Do you have try with a joomla fresh install ?

No. It is an older installation (updated to current version of Joomla). Did you find a solution?

I’m seeing this same problem with Magento 1.9x, anyone else found a solution?

Same problem here. Magento 1.9.x as well.

+1 same problem here.

Same problem with mootools here.

How many same problem here, we need to gain attention?

Please guys on Mautic, give us a hand here.

In my case the tracking works fine but this conflict seems to be causing issues with another extensions… I tought that i was putting the code in a wrong place but im seeing with this conversation that actually is placed the right way.

Hope can anybody help us.

Best regards.