Upgrade from MAUTIC 4.4.11 --> 5.0.2 problem

Your software
My Mautic version is: 5.0.2
My PHP version is: 8.0.28
My Database type and version is: MySQL 8.0.35

Your problem
My problem is:
After upgrade from 4.4.11 → 5.0.2 I’m getting red offline error message (see screenshot below) in the browser along with the ‘parameter x must be defined’ error(s) when running commands such as (doctrine:migrations:migrate) via CLI.
I am currently running 4.4.11 again (restored from backup).

*Had no problem upgrading from 2 → 3 and from 3 → 4 with all the intermediate stable version upgrades.

These errors are showing in the log:
Seems like the major problem is the “2FXXXXX” is not defined.
This is the ‘mailer_dsn’ / AMAZON SES/ special character in password issue talked about here:

After commenting out ‘mailer_dsn’ line the ‘is not defined’ error doesn’t appear when running console command such as ‘cache:clear’. But red ‘offline’ message still shows when browsing to Mautic via browser.

Steps I have tried to fix the problem:

  • Commenting out ‘mailer_dsn’ in local.php.

@omert did you clear the cache after commenting out that line?

Can you check the logs (Apache / PHP / Mautic) for any pointers?

Please don’t create alle separate forum topics and github issues for variants of the same issue. This makes it hard to track and poinpoint the same issue.

Yes. I cleared the cache (cache:clear) after commenting that line.
Cache was cleared successfully but red “offline” message still shows in browser when surfing over to mautic.


can you try by removing the var/cache/prod folder?
Sometimes the Symfony cache:clear command doesn’t have the foreseen result.

I tried something like that already the first time around when I upgraded from 4.4.10 → 5.0.1.
It didn’t work then.
I’m very much reluctant to upgrade again just to try it.