Mautic Community Forums

2.12.1 Released!

We’re happy to announce that our 2.12.1 has been released! Read the full release notes here.

If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php. If you are on a VPS, be aware of the user used to execute that command as you may have to fix the owner to be that of your web user. Be sure to remove this file once the upgrade is complete.

Alternatively, you can use the in-app upgrade process:

Click Update Now and follow the prompts.

If you have any issues – be sure to checkout John’s post.

Happy Marketing!

The Mautic Team

Not again !
There was error generated during update of 2.12.0. It just lingered on “Moving Package Contents”.
Had high hopes for 2.12.1. And it does exactly the same thing.
At the minimum there should be “update” remedial tutorial, sharks are out there who wants your wallet for every upgrade exigencies experienced by a user. And Mautic just satisfies them rather than their users becoming good ambassadors.
No wonder reviews on the internet and social media are saying so.
It seems “mautic” has more bugs than the whole universe specie count
Imagine if your Windows Update required paying someone for every update to rectify the issue.

Open source WordPress works like a charm, unlike Mautic. Perhaps Mautic needs to learn from them !

@linusk I had the same problem with the previous update (haven’t run this one yet).

I solved it by running the update from the command line (fyi nothing was corrupted from what I can tell when the update hung on “moving package contents” so I didn’t have to restore from a backup before doing it the command line way.

Inspired by: https://www.mautic.org/community/index.php/8914-mautic-upgrade-undefined-status/0

$php app/console cache:clear
$php app/console mautic:update:find
$php app/console mautic:update:apply (Follow the prompts)
$php app/console cache:warmup

I actually installed Mautic on My Siteground Host using cPanel.

Therefore these steps will not resolve it …

@linusk Siteground do offer ssh access for cpanel so the above details should be able to help.

FYI: https://www.siteground.com/tutorials/ssh/

Thanks for this info, I just newly migrated to Siteground.

Previous shared host provider did not have this.

I have to look at this.

Thanks again

thanks for sharing.
I’m newbie and new on mautic, I have ssh access but I didn’t understand how to upgrade. If you make a video tutorial for newbies it will be perfect

@ebk abdel i can do for you

Bizcrony thank you. how Can you explain?
“we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php.”

I made the upgrade on mautic: doesn’t work
I made it with ssh: works
Thanks again

copy what’s on this page:
https://raw.githubusercontent.com/mautic/mautic/master/upgrade.php

open notepad and past it then save the file and give it this name: upgrade.php

put upgrade.php on mautic root using FileZilla

open chrome then enter to your mautic directory+upgrade.php
ex: https://www.???.org/mautic/upgrade.php

click on start upgrade and wait

after 5 minutes you will get a success message

remove upgrade.php from mautic root with filezilla

enter and enjoy mautic

why not making a stupid tutorial like that for newbies? I don’t understand

@ebk abdel there are three ways to upgrade mautic.

  1. From dashboard Notification
  2. With upgrade.php file
  3. BY ssh

all process are good …but sometime it works either.

This forum is for release announcements only. If you have trouble with a release, or simply want to voice your frustration about an upgrade please post in a different channel. In the future posts will be moderated and removed from this specific forum to keep the topic on release announcements.

Hi, if i want to update from the dashdoard, i get the following statement in the error log file

[2018-01-30 00:16:04] mautic.WARNING: PHP Warning - setcookie() expects parameter 3 to be integer, float given - in file /var/www/vhosts/mautic3.xxx.de/app/bundles/CoreBundle/Helper/CookieHelper.php - at line 71 [] []

Update with php file, following error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Wat php version you are

i have Mautic running with PHP Version 7.0.27

if i log in with ssh with root ubuntu 12.04.4 is running with PHP 5.3
The vserver is running with PHP Version 7.0.27

i am running php7.0 i changed to 5.6 it looked like it will work better from the dashord but it is hanging at the point: Moving Package Contents

now it worked with php5.6 and the php script
thank you