Mautic Community Forums

2.8.0 Released!

We’re happy to announce that 2.8.0 has been released! Read the full release notes here.



If upgrading from earlier than 2.6.0:

If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php. If you are on a VPS, be aware of the user used to execute that command as you may have to fix the owner to be that of your web user. Be sure to remove this file once the upgrade is complete.



If upgrading from 2.6.1 or later:

Since this does not include any schema changes, the update process built into Mautic’s front-end will suffice in updating. Simply log out, back in, and you should see the upgrade notification similar to:



update_available.png



Click Update Now and follow the prompts.



If you have any issues - be sure to checkout John’s post.



Happy Marketing!



The Mautic Team

We’re happy to announce that 2.8.0 has been released! Read the full release notes here.

If upgrading from earlier than 2.6.0:
If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php. If you are on a VPS, be aware of the user used to execute that command as you may have to fix the owner to be that of your web user. Be sure to remove this file once the upgrade is complete.

If upgrading from 2.6.1 or later:
Since this does not include any schema changes, the update process built into Mautic’s front-end will suffice in updating. Simply log out, back in, and you should see the upgrade notification similar to:

Click Update Now and follow the prompts.

If you have any issues - be sure to checkout John’s post.

Happy Marketing!

The Mautic Team

Easy peasy upgrade. Now to see if it does what it says on the tin.

God bless the upgrade.php script! 30 seconds upgrade with no hassle. God bless mautic team and community!

What’s new in this version?

Upgraded from 2.7.1 to 2.8. Upgrade was a success but the configuration page won’t load. The rest seems fine. After digging into it…
I tried clearing cache but that didn’t help (the clearing was a success though).

I then found this which started right after the upgrade:
PHP Notice: Undefined index: username in /var/www/mautic/app/bundles/SmsBundle/Api/TwilioApi.php on line 59
PHP Notice: Undefined index: password in /var/www/mautic/app/bundles/SmsBundle/Api/TwilioApi.php on line 59

Any ideas?

Thanks

Alright I just figured this out… this might help some other people as the behaviour was totally unexpected…

I was adjusting my mail server’s firewall settings just before performing the upgrade. I had set a rule that no longer allowed the mautic server to access the mail server (for both sending (SMTP) or receiving email (IMAPS)).

For some reason, I suppose mautic checks connections to configured email servers if they exist when loading the configuration page, but doesn’t seem to have a time out in case the server can’t be reached so it just hangs there with the blue bar going across the screen.

As soon as I dropped the restrictive firewall setting on the mail server, the configuration page loaded right back up. I tested the behaviour a few times and it’s consistent.

Still don’t know what the story is with the two PHP notices I posted above that started after the upgrade. Especially since I don’t have a twilio account and don’t use any SMS features…

Anyway, keep up the good work! Thanks for a fantastic product.

N.B. So to clarify, I don’t know if the bug is related to the upgrade specifically because I didn’t try that mail server restriction vis-a-vis the configuration page any time prior, so the bug might have been there before.

@MxyzptlkFishStix Beauty! That fixed the PHP Notices. Thank you!

As soon as I modified the two files the Notices disappeared.

what I got when trying to update

1-4 did not work, so I posted the image. only remaining is 5. will try this and give feedback.

this is the latest log i find. no newer, although I made the update 27.04.2017

[2017-04-13 13:51:11] mautic.ERROR: SymfonyComponentDebugExceptionFatalThrowableError: Call to a member function getId() on null - in file /app/bundles/EmailBundle/Helper/PointEventHelper.php - at line 30 [] []

Update got stuck at the “Clearing Application Cache In Progress” stage :frowning:

Installed 2.8.0 SMOOTH … Like BUTTAH… first time an update actually FINISHED … Nice Work Guys!

Looks like a good upgrade, the update went smooth. Thanks.

Hey guys,

Updated using the script just to be safe, but still ended up bricking our installation.

The error log now says:
[Thu May 04 15:18:08.397216 2017] [:error] [pid 1100] [client 63.143.42.244:37774] PHP Fatal error: Class ‘ComposerAutoloaderInita88617c0a465e970823a94ff8b88fbb2’ not found in /var/www/mautic/vendor/autoload.php on line 7

During the upgrade the script told me I had to manually delete the cache, and so I did. Didn´t help though.

I was upgrading from the previous version, so there shouldn´t have been any schema changes either.

I tried the basic steps of this article :https://johnlinhart.com/blog/uh-oh-mautic-upgrade-was-not-successful
But I´m not able to run any php-commands, as they say the same thing as listed above.

What to try next?

Br.
Patrik

I managed to get it working again, I set the version number in the version.txt back to 2.6.1 and ran the upgrade with sudo. Then I had to delete the cache folder again and now it works.

Found that guide here: https://www.mautic.org/community/index.php/5385-2-1-1-released-critical-upgrade/0 (Answer by Scully on 29th of august 2016.

Br. Patrik

I upgraded from 2.5.1 to 2.8.0 and after the upgrade I am seeing the following getting logged in the logs folder. How can I resolve this issue?

mautic.CRITICAL: Uncaught PHP Exception DoctrineORMORMInvalidArgumentException: “A new entity was found through the relationship ‘MauticEmailBundleEntityStatDevice#stat’ that was not configured to cascade persist operations for entity: MauticEmailBundleEntityStat@00000000452f4e3000007f075ffefdc5. To solve this issue: Either explicitly call EntityManager#persist() on this unknown entity or configure cascade persist this association in the mapping for example @ManyToOne(…,cascade={“persist”}). If you cannot find out which entity causes the problem implement ‘MauticEmailBundleEntityStat#__toString()’ to get a clue.” at /public_html/vendor/doctrine/orm/lib/Doctrine/ORM/ORMInvalidArgumentException.php line 92

I have run the DB migrations and also cleared cache but no luck. Please advise.

Any help is greatly appreciated.

also 5. did not work out. so now I try a complete new installation, but it is stuck at /installer/step/1.1

serverlog:
FastCGI: comm with server “/fcgi-bin-php5-fpm-www-7.0” aborted: idle timeout (30 sec)
FastCGI: incomplete headers (0 bytes) received from server “/fcgi-bin-php5-fpm-www-7.0”