4.2.1 Installation Failed

Your software
My Mautic version is: 4.2.1
My PHP version is: 7.4
My Database type and version is: MySql 8

Your problem
My problem is: Used the web updater to update to 4.2.1. UPgrade failed at cache clear (UI became unresponsive), after manual clear, Mautic offline completely.

These errors are showing in the log:

About 10 symfony errors stating that they cannot overwrite certain files (liek URLGenerator.php). My permissions are all OK just to be clear.

Steps I have tried to fix the problem: None. Not sure how to fix my broken mautic install without wiping it out and starting it over. Is there a command line upgrade I can run somehow?

And just to be more clear - I already tried all the mautic:update stuff from the command line that Im aware of. Im wondering if there is a way to force it to re-apply the update to hopefully fix whatever blew up.

Revert installation from backup and try to upgrade again from cli

from fresh install I have same problem, also in command line.
Here the error log :
Doctrine\DBAL\Exception\SyntaxErrorException: An exception occurred while executing 'ALTER TABLE kix_lead_event_logRENAME INDEXIDX_SEARCHTOkix_IDX_SEARCH': SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'INDEX IDX_SEARCHTOkix_IDX_SEARCH' at line 1 (uncaught exception) at /mautic-features/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 98 while running console command doctrine:migrations:migrate [] []

Best regards

mysql version issue

@mzagmajster - Did what you recommended. Tried CLI update, seems to update perfectly this way.

Files were copied over properly, Symfony didnt throw any errors that I could find about not being able to copy files so it seems to have worked fine for me as a CLI update.

Im now wondering why it failed during the web update… seems like the process would be the same in terms of permissions and procedure as a cli update.

From a usability standpoint, I personally think losing the web install in v5 is a mistake.

Only technical users will be able to update the system, most typical SMB’s will have a problem with ssh and cli updates I think. Even composer would be a stretch I think - but if there is a technical issue that makes necessary, I understand the reasoning.

Do you have any insight on this?

I have to agree with @deepti - that issue says to me its a mysql version issue. Make sure you have the latest version of MariaDB installed or consider switching to MySQL 5.7+.

As far as I know the preferred way to update is cli command, because it provides more consistent / reliable way to update the app. There was a google doc. a while back that answered exactly the question you posted above.

As for not being friendly to non-tech users:

  • if I would to be in the position of non-tech users I would hire external help to take care of technical aspect of Mautic - which includes the upgrade of the application
  • Or simply try to follow the procedure to update from documentation (and if you encounter issues you still have the forum - just like before)

Ok, I ll try to upgrade.
The current version is 10.4.14
Thanks for reply

If I check requirements, it should be ok : MariaDB 10.2 .

My version is : 10.4.14

Maybe update the requirement as RENAME INDEX start with MariaDB 10.5.2

@kixell - Keeping up with the documentation is definitely something that is a priority. Thank you for the additional info.

@rcheesley how would I go about updating the requirements to reflect this information? Is there someone to notify on slack?

Hi all, I confirm that upgrading MariaDB solve the problem.
I needed to upgrade my Debian :slight_smile: but now with MariaDB 10.5.15 the upgrade run successfully.

Best regards,