Mautic Community Forums

Version 2.13.1 update fails

When attempting to update to Version 2.13.1 of Mautic, the update completes but then an error message displays that the install is broken.

This happened on three domains.

I restored from a backup and tried again and the same thing happened.

Is there something wrong with the update?

Try updating it using ssh and running php 7.
Here is what I usually do:

  • rm -rf app/cache/prod
  • php70 app/console mautic:update:find
  • php70 app/console mautic:update:apply

@mediamix you need to migrate database also

how do we migrate the database?

@alfredosimoes php app/console doctrine:migration:migrate

I tried upgrading to mautic 2.13.1 again and am having the same problem.
Install crashed at last step when it is clearing cache.

My server is an Ubuntu 16.04 with ISPConfig.

I have ungraded in the past with no problem.

Prior to this upgrade there were files in the /var/www/clients/client1/web6/web/mautic/app/cache/prod and owner/group of all folders are web6/client1

After the crash, the ip_data, prod and run folders remain while the files within those folders are gone.

Given that upgrades have worked in the past, and permissions have not been changed, I have to think that there is an issue with the update.

Any thoughts?

@mediamix how did you try to upgrade the mautic ?

As you know, when logged in to Mautic there is a bell icon to the right of the Mautic logo in the upper left corner.

Clicked on the bell and then Clicked on update now.
This is the same way that I have upgraded in the past.
By the way, the version I was trying to upgrade to is 2.14.0

Thanks for the help

Joe

@mediamix to upgrade mautic by bell sometimes not work properly.

So you have a procedure that works?